incorrect rendering of nested SVG gradients

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: martin.hejral, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050912 Firefox/1.6a1

SVG specification allow nested SVG gradients like this:

    <linearGradient id="gradientSRGB" 
      color-interpolation="sRGB" xlink:href="url(#gradient)" >
    </linearGradient>
    <linearGradient id="gradientLRGB" 
      color-interpolation="linearRGB" xlink:href="url(#gradient)" >
    </linearGradient>

but this code will crash Mozilla!!!

Reproducible: Always

Steps to Reproduce:
please open test case, if you will crash Mozilla :-)
Actual Results:  
crash
(Reporter)

Comment 1

13 years ago
Created attachment 196662 [details]
test case
(Reporter)

Comment 2

13 years ago
Comment on attachment 196662 [details]
test case

ADOBE SVG Viewer 3 render this graphics uncorrectly too!!! (KSVG works good.)
The crash was fixed in bug 307742. However, with a patched FF the gradient
doesn't show on the second and third rect for some reason so leaving this open
for now.
Severity: critical → normal
OS: All → Windows XP
(Reporter)

Updated

13 years ago
Summary: nested SVG gradients will crash Mozilla → incorrect rendering of nested SVG gradients

Comment 4

13 years ago
This bug should be marked CLOSED.  The reason the second and third gradients
don't show is that the example uses "url(#gradient)" as an XLINK target.  While
the "url()" syntax is supported for SVG attributes, its not supported by
xlink:href.  Change the example to xlink:href="#gradient" and the example
renders as expected.
Oh, quite right. I should have noticed that. Marking invalid then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

13 years ago
Created attachment 196763 [details]
correct SVG example works, thanks
You need to log in before you can comment on or make changes to this bug.