If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

www.projo.com: ((SCRIPT && STYLE) in TABLE) => duplicate rows

VERIFIED DUPLICATE of bug 2701

Status

()

Core
HTML: Parser
P2
normal
VERIFIED DUPLICATE of bug 2701
19 years ago
11 years ago

People

(Reporter: John Morrison, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This HTML (below) produces the following. (Reduced from www.projo.com)

             +-------+-------+
             | (1,1) | (1,2) |      <-- duplicate row
             +-------+-------+
             | (1,1) | (1,2) |
             +-------+-------+
             | (2,1) | (2,2) |
             +-------+-------+

1) Removing *either* the <SCRIPT></SCRIPT> or the <STYLE></STYLE> lays
out the table correctly. (And, yes, the <STYLE> should definitely not
be there, but it's in the original HTML in that location)

2) Reversing the positions of SCRIPT and STYLE eliminates the error
(i.e., put STYLE in the first row and SCRIPT in the second row).

(Tested on Feb06 Win95 non-debug build). [Note: this is not the same
bug as the old one (#1224) which is FIXED.]

 ==============================
<html><head></head><body>
<table border="1" width="400">
  <tr>
    <td>
       (1,1)
    </td>
    <td>
       (1,2)
      <SCRIPT></SCRIPT>
    </td>
  </tr>
  <tr>
    <td>
       (2,1)
      <STYLE></STYLE>
    </td>
    <td>
       (2,2)
    </td>
  </tr>
</table>
</body></html>

Updated

19 years ago
Assignee: rickg → karnaze

Comment 1

19 years ago
Chris -- This is not a parser bug as stated. If you dump the content model, it
appears correctly.

Comment 2

19 years ago
Hey, John ---

Killer decomposition. You rock. What you're describing sounds like the bug that
3054 describes (view source on the http://www.ea.com/static_main.html frame).

Do you think it's a duplicate?
(Reporter)

Comment 3

19 years ago
As it turns out, no, not a duplicate. #3054 appears to be a problem with
document.write, and I put a test case to show the problem over at #3054.
.. John

Comment 4

19 years ago
<Thanks for checking. We are not worthy. ;->
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

19 years ago
Not worthy?

*** This bug has been marked as a duplicate of 2701 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Verified Dup of Bug 2701

Updated

11 years ago
You need to log in before you can comment on or make changes to this bug.