Closed Bug 309287 Opened 15 years ago Closed 14 years ago

{inc}width of containg div no longer reflow when image inside is changed

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mkmelin, Unassigned)

References

Details

(Keywords: regression, testcase, Whiteboard: [reflow-refactor])

Attachments

(2 files)

See testcase. When changing the image in a div, the div containing it does no
longer adjust accordingly.
In the testcase, the size of the red div should shrink back when the image
inside it does not need the extra space. 

This works fine in firefox1.0.x, opera8, ie6. Broken on branch, I can reproduce
going back at least to 1.8a6.
Attached file minimized testcase
Confirming Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
Gecko/20050913 Firefox/1.6a1

Also noting, if I click elsewhere on the page (removing the selected link's
outline), it will resize accordingly at that point.
(In reply to comment #2)
> Also noting, if I click elsewhere on the page (removing the selected link's
> outline), it will resize accordingly at that point.

Yeah, seems it shrinks to the correct size when the text is clicked. 

The reflow will also happen if you resize your browser window while "too much is
showing". BTW, I see this on linux too.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Aaron, David: any take on this regression? Caused by fix for bug 151375?
Summary: width of containg div no longer reflow when image inside is changed → {inc}width of containg div no longer reflow when image inside is changed
Whiteboard: [reflow-refactor]
Overflow problem with absolutely positioned div inside absolutely positioned div.
That testcase was also attached to bug 301726; it's probably not relevant to this bug either, although I didn't look closely.
(In reply to comment #7)
> That testcase was also attached to bug 301726; it's probably not relevant to
> this bug either, although I didn't look closely.
> 

It took me more time to try find a duplicate for my bug than to find an workaround for it.
Should I fill in a new bug with my testcase?
Testcases WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060817 Minefield/3.0a1 ID:2006081709 [cairo]
(In reply to comment #9)
> Testcases WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1)
> Gecko/20060817 Minefield/3.0a1 ID:2006081709 [cairo]

Nope, the red box still does not go back to being small. Problem still there in
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060819 Minefield/3.0a1 ID:2006081904 [cairo]
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
-> FIXED by reflow branch landing!
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.