Users need simple method to report phishing sites

RESOLVED DUPLICATE of bug 329292

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 329292
13 years ago
12 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918 Firefox/1.6a1

Currently, the average user has no idea how to report a phishing site should
they come across one and as a result, these sites may not be getting reported
and taken down as quickly as they could be.

Ideally, the browsers and mail clients should provide an additional option under
the help menu (like the report broken web site option) which sends them to a
localised phishing reporting site - perhaps even pre-filling some data based on
the web page currently displayed.

Reproducible: Always

Steps to Reproduce:




There is a topic on Mozillazine at
http://forums.mozillazine.org/viewtopic.php?t=319412 which mentions some other
ideas that may sit well with this log - e.g. centraly maintained database of bad
sites which could be used to proactively prevent users visiting them once a site
is known.
(Reporter)

Comment 1

13 years ago
Although logged against Firefox, this should equally apply to all Mozilla
browsers and mail clients.

Comment 2

12 years ago
This was implemented in 2.0 (Help>Report Web Forgery...)
http://www.mozilla.com/en-US/firefox/phishing-protection/

There is also bug 328749 to implement something similar in Thunderbird

*** This bug has been marked as a duplicate of 329292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.