crash when imap server goes down.

VERIFIED FIXED in M14

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 3/8)

I noticed this a bunch today, because tintin kept going down.

here's the fix for the crash:

Index: nsImapProtocol.cpp
===================================================================
RCS file: /cvsroot/mozilla/mailnews/imap/src/nsImapProtocol.cpp,v
retrieving revision 1.232
diff -r1.232 nsImapProtocol.cpp
831c831
<   if (NS_SUCCEEDED(rv) && TestFlag(IMAP_CONNECTION_IS_OPEN))
---
>   if (NS_SUCCEEDED(rv) && TestFlag(IMAP_CONNECTION_IS_OPEN) && m_ouputStream)

basically, the m_outputStream is not there, and we try to send
"logout" over it.
whoops, I spelled outputStream wrong in that patch.

marking beta1, I keep seeing this and it hurts my own dogfood efforts.
Status: NEW → ASSIGNED
Keywords: beta1, dogfood
Target Milestone: M14

Comment 2

18 years ago
[PDT+] w/b minus on 3/8. No big changes, please. Defensive null pointer test 
only.
Whiteboard: [PDT+] w/b minus on 3/8
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
*** Bug 30807 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: lchiang → fenella

Comment 5

18 years ago
Seth,
To re-test this bug, can I just un-plug the network plug or I have to try to
physically turn off a test sever?
thanks for advise.

Comment 6

18 years ago
Seth, I am unable to bring down the tin-tin imap server to re-test this bug. So
I used the imap server in the lab.
steps:
1. Create an imap account parp30 using the parp.mcom.com server
2. Bring up Messenger and load the messages from the server using the parp30
account.
3. View the message, no problem
4. Now stop the parp.mcom.com server
5. Back to Messenger, and click on a message, it does not crash applicaction any
more.
Status: RESOLVED → VERIFIED
try this:

connect to an imap server.  read mail.

unconnect your ethernet cable.

hit get new messages.

see http://bugzilla.mozilla.org/show_bug.cgi?id=30807 for another way to 
reproduce

Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.