scrollwheel doesn't work in non-toplevel window

RESOLVED FIXED

Status

Core Graveyard
Widget: Mac
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Josh Aas, Assigned: Mark Mentovai)

Tracking

({fixed1.8})

Trunk
PowerPC
Mac OS X
fixed1.8
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
If you open the "Report Broken Web Site" tool, you can't scroll any of the
iframe elements with a scrollwheel (license agreement, submitted report view at
the end of the wizard). Also, you can't scroll the hierarchy view when adding a
bookmark.
(Assignee)

Comment 1

12 years ago
Not an iframe issue, a window type issue.  In nsMacWindow, the scroll CE handler
is only registered if mWindowType == eWindowType_toplevel.

Scroll wheel support was added by pinkerton in rev 1.95 of nsMacWindow.cpp, bug
71045.  There's your daily blast from the past.  There doesn't appear to be a
good reason for it to be in the conditional, other than that it was a convenient
place to add the code.  I'm either going to remove the conditional (installing
the handler regardless of window type) or expand the list of window types that
get the handler.
Status: NEW → ASSIGNED
Flags: blocking1.8b5?
Summary: scrollwheel doesn't work in iframes → scrollwheel doesn't work in non-toplevel window
(Assignee)

Comment 2

12 years ago
Created attachment 196852 [details] [diff] [review]
Patch

This installs the scroll wheel event handler on all window types except
invisible, plugin, and java.  For the bug reported here, it needs to be on
dialog, and for the bookmark add UI, it needs to be on sheet.  Note that popup
gives scroll wheel control of <select> elements.
Attachment #196852 - Flags: superreview?(sfraser_bugs)
Attachment #196852 - Flags: review?(bugs.mano)
Comment on attachment 196852 [details] [diff] [review]
Patch

r=mano
Attachment #196852 - Flags: review?(bugs.mano) → review+

Updated

12 years ago
Attachment #196852 - Flags: superreview?(sfraser_bugs) → superreview+
(Assignee)

Comment 4

12 years ago
Time from open to close = 1 hour.  That includes 15 minutes I spent on the bus.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Attachment #196852 - Flags: approval1.8b5?

Comment 5

12 years ago
This is a pretty noticeable issue on the Mac. I recommend that we take this fix
for 1.8b5.

Updated

12 years ago
Attachment #196852 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Comment 6

12 years ago
fixed1.8
Keywords: fixed1.8

Updated

12 years ago
Flags: blocking1.8b5? → blocking1.8b5+
*** Bug 236909 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

12 years ago
*** Bug 312892 has been marked as a duplicate of this bug. ***

Updated

8 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.