autocomplete=off stops password manager

RESOLVED DUPLICATE of bug 245333

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED DUPLICATE of bug 245333
12 years ago
9 years ago

People

(Reporter: Trevan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20050920 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20050920 Firefox/1.4

I had always wondered why Firefox didn't save the password on my bank page.  I
finally decided to go search bugzilla and find out why.  I found bug #242115
that showed someone with the same problem as mine, and so since it hadn't been
touched in a while, I added a comment.  But today, I decided to create a simple
test to see what actually was stopping Firefox and it turned out that it was the
autocomplete=off setting.  Looking at Firefox code, I found the spot that
actually caught this case.

Now, what I am requesting is that I can still make Firefox remember the
password.  In my mind, the password saving is not a form autocomplete feature. 
That is when Firefox saves other things I type into forms.  I see the password
manager as a way to remember all the passwords that I have to keep track of. 
And since I can't change the site to have autocomplete=on, I would like to make
Firefox override that, but only for the username and password fields.  If there
are other fields in the form, those should have autocomplete=off.

Reproducible: Always

Steps to Reproduce:
1. Enter password
2.
3.

Actual Results:  
It doesn't ask me to save the password

Expected Results:  
I think it should
What you wanted to find was bug 63961 for the history (short version: either we
support autocomplete=off for usernames and passwords, or banks will block our UA
string) and bug 245333 for the repeated wontfixing of changing that in what we
ship (and any number of mentions of various workarounds).

*** This bug has been marked as a duplicate of 245333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.