If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

the file name with spaces is cut on the first space in case of Content-Disposition: attachment; filename=

VERIFIED DUPLICATE of bug 221028

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 221028
12 years ago
9 years ago

People

(Reporter: Ivo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

if the script send the file with spaces in his name to the browser with the
Content-Disposition header for example:

Content-Type: image/gif
Content-Disposition: attachment; filename=My File.gif

only the the first word ("My" in the above example) is selected as a default
file name.

Reproducible: Always

Steps to Reproduce:
1. it is written in the details
2.
3.
The correct way is:

Content-Disposition: attachment; filename="My File.gif"

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.