Template-generated menulist popups change selection when opened via keyboard

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Karsten Düsterloh, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed1.8, regression})

Trunk
x86
Windows 2000
fixed1.8, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

677 bytes, patch
Karsten Düsterloh
: review+
Scott MacGregor
: superreview+
Scott MacGregor
: approval1.8b5+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
If you open a template-generated menulist popup (eg. Location toolbar in
MailNews and search location dropdown on MailNews' search dialog) via
ALT-downarrow, the selection changes also. This is not the case for 'normal'
menulists.

Seen with self-built SeaMonkey Win2k trunk nightly of 2005-09-21.
(Assignee)

Comment 1

12 years ago
Created attachment 197331 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #197331 - Flags: superreview?(mscott)
Attachment #197331 - Flags: review?(mnyromyr)
(Reporter)

Comment 2

12 years ago
Comment on attachment 197331 [details] [diff] [review]
Proposed patch

Does as intended on Win and does no harm on Mac...
Attachment #197331 - Flags: review?(mnyromyr) → review+

Comment 3

12 years ago
Comment on attachment 197331 [details] [diff] [review]
Proposed patch

Neil, do you think this is something we should add to the 1.8 branch?
Attachment #197331 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 4

12 years ago
Fix checked in to the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

12 years ago
Comment on attachment 197331 [details] [diff] [review]
Proposed patch

>Neil, do you think this is something we should add to the 1.8 branch?
Yes, it has the bug too, and the fix is trivial.
Attachment #197331 - Flags: approval1.8b5?

Comment 6

12 years ago
Comment on attachment 197331 [details] [diff] [review]
Proposed patch

this has no impact on Firefox at all.
Attachment #197331 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Updated

12 years ago
Keywords: fixed1.8

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: xptoolkit.menus → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.