Firefox downloads the English update when I updated my zh-TW Firefox 1.0.6

RESOLVED FIXED

Status

Mozilla Localizations
Other
--
blocker
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: wctaiwan, Assigned: Hung-Te Lin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 (ax)

When I updated Firefox 1.0.6 (Chinese) through the Automatic Update Checker,
Firefox said that there is an upgrade available for the main program. I
performed the upgrade (i.e. downloaded Firefox through the checker), installed
Firefox 1.0.7 (the installation program was in English while it was supposed to
be in Chinese), and my Firefox's interface became English. This problem has
never occurred when I tried to update from an old version to a relatively newer
version before.

Reproducible: Didn't try

Steps to Reproduce:



Expected Results:  
Firefox should be in Chinese.

Updated

13 years ago
Component: Installer → Software Update
QA Contact: installer → software.update
This bug is a little confusing. zh-TW 1.0.7 is not being offered by the update
system just yet. And your BuildID has '(ax)' in it. Is this a third-party build
or do you have an ActiveX plugin installed ?

Did you create this bug using the updated build ?
After some digging, I have confirmed that (ax) is added to the User-agent by the
Activex Plugin at http://www.iol.ie/~locka/mozilla/plugin.htm (I looked at the
Firefox 1.0.4 xpi). So I think we can ignore that.

More importantly I can reproduce this bug by installing Firefox 1.0.6 zh-TW and
checking for updates. The inital UA is
Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-TW; rv:1.7.10) Gecko/20050717
Firefox/1.0.6

The app loads this url when checking for updates (info from LiveHTTPHeaders)
 https://update.mozilla.org/update/firefox/en-US.rdf?127
and offers
 Firefox 1.0.7 (en-US) Software Update   from: download.mozilla.org
Spot checks of other locales (en-US, en-GB, nl-NL) gave results as expected. 

The problem seems to be the line 
 app.update.url=https://update.mozilla.org/update/firefox/en-US.rdf 
in 
 zh-TW.jar:/locale/chrome/locale/mozapps/update/update.properties

This problem exists in 1.0.6 and 1.0.7 versions, but not 1.0.4 or earlier, and
is due a change made in bug 299712 (attachment 188313 [details] [diff] [review]).

Updated

13 years ago
Assignee: nobody → piaip
Blocks: 309660
Severity: minor → blocker
Status: UNCONFIRMED → NEW
Component: Software Update → Other
Ever confirmed: true
Product: Firefox → Mozilla Localizations
(Assignee)

Comment 3

13 years ago
My mistake. I used beta URLs to verify update process and
forgot to verify the url in real release.
Solved in fx 1.5.

P.S: Should we still fix this in aviary branch, pike?
Status: NEW → ASSIGNED
-> (approximately) default QA assignee.
QA Contact: software.update → nobody

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.