Using JavaScript, 'document.abc has no properites' error occurs on valid code...error 0x80070057 in JavaScript console

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: js-777, Unassigned)

Tracking

1.0 Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Using the syntax
     document.<form_name>.<object_name>.<property>
or
     document.<object_name>.<property>
fails, and says it has no properties.

This syntax works perfectly in IE6.

What is strange, is that with the
     document.<form_name>.<object_name>.<property>
syntax, it works correctly in Firefox 1.0.7, but I still get the error in the
JavaScript Console that the form/object has no properties.

But, when I tried the same syntax to change the SRC of an IMAGE tag, it fails
(and again, works fine in IE6).

I've tried
     document.myForm.my_IMG_name.src
     &
     document.myForm.my_IMG_id.src
     &
     document.my_IMG_name.src

After clicking on the Source File link to this error in the JavaScript Console,
I get:
uncaught exception: [Exception... "Component returned failure code: 0x80070057
(NS_ERROR_ILLEGAL_VALUE) [nsIWebNavigation.loadURI]" nsresult: "0x80070057
(NS_ERROR_ILLEGAL_VALUE)" location: "JS frame ::
chrome://global/content/viewSource.js :: viewSource :: line 140" data: no]

This appears to be a big problem in Firefox.
When searching on "0x80070057", here are just a few that got very similar error
messages.

http://lists.suse.com/archive/suse-linux-e/2005-Jan/4820.html

http://weblogs.mozillazine.org/asa/archives/007898.html

http://weblogs.mozillazine.org/asa/archives/007945.html

http://freetextbox.com/forums/ShowPost.aspx?PostID=4520


I'm just using HTML and JavaScript locally on my machine in an HTML file, and it
fails in Firefox 1.0.7.

Reproducible: Always

Steps to Reproduce:
Created attachment 197411 [details]
testcase

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050926
Firefox/1.4 ID:2005092603

WFM

My guess is that either an extension or one of your settings is blocking the
script

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050926
Firefox/1.6a1 ID:2005092604

WFM. Please reopen if you can reproduce in the latest trunk builds.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 1.0 Branch
(Reporter)

Comment 3

13 years ago
Amazing!!

What caused this error, and the page to fail to fully load using onLoad in the
BODY tag, was an IMAGE tag I put in the middle between the BODY tags as a place
holder with just the path to where I would put the image, but I left out the
file name.

This caused it to failed to fully load, since it used JavaScript to get the
initial image, and all of the JavaScript used to switch images, even though this
image was never clicked on (surrounded by the ANCHOR tag).
<img src="../aa/bb/">

Putting in a file name, even an invalid file name, made it work.
<img src="../aa/bb/abc.jpg">

This only occurred in Firefox 1.0.7.
This did not occur in IE6.

Firefox should not allow something as minor as this to screw up all of the
scripting in the page, and throw errors that are completely misleading.

For example, I got scripting errors when the JavaScript was completely correct.
It was an HTML tag that was syntactically correct, but missing the file name in
the SRC attribute.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Please use a recent version of Firefox, available at
http://www.mozilla.com/en-US/firefox/, and report back with your results in
relation to this bug report.

If this problem can be reproduced, please reopen this bug report. Due to age/lack of response, closing. (bug cleaning)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.