Last Comment Bug 310100 - rules="all" does not work when table has no border
: rules="all" does not work when table has no border
Status: RESOLVED FIXED
: fixed1.8, regression, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: P1 major (vote)
: mozilla1.8beta5
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
:
Mentors:
https://bugzilla.mozilla.org/attachme...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 13:24 PDT by Gérard Talbot
Modified: 2005-09-27 11:46 PDT (History)
4 users (show)
mconnor: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (753 bytes, patch)
2005-09-26 19:43 PDT, Boris Zbarsky [:bz] (still a bit busy)
bernd_mozilla: review+
dbaron: superreview+
asa: approval1.8b5+
Details | Diff | Splinter Review

Description Gérard Talbot 2005-09-26 13:24:55 PDT
This spins off of bug 226593

Steps to reproduce:
1- Load provided URL
2- Click the "All borders" button

Actual results: table rules are not visible

Expected results: table rules are visible
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2005-09-26 14:26:02 PDT
Dynamic changes aren't even needed; it looks like we just broke rules="all" for
the case when the table has no border set -- this is a regression from bug 155507.

The problem is that the only reason rules="all" worked is that the post-resolve
callbacks in nsHTMLStyleSheet mapped border styles onto table rows, cols, and
colgroups.  Now that we're not collapsing borders for rules="all", this does
absolutely nothing, of course...

For 1.9 we should just work on fixing bug 43178, but for 1.8 I see a few
options, I guess:

1)  Back out the patch for bug 155507.
2)  Add a post-resolve callback for table cells (and probably remove the
    existing ones)
3)  Fix bug 43178 for 1.8 (this kinda scares me, to be truthful).
4)  Leave this broken in 1.8 and tell people to set the border (I'm not happy
    with this approach, frankly).

Did I miss anything?  David, option #3 sounds best to me if you think it
wouldn't be too slow...
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2005-09-26 19:43:57 PDT
Created attachment 197501 [details] [diff] [review]
Patch

It's probably better to back this part out for now, pending bug 43178 being
fixed.
Comment 3 Bernd 2005-09-26 21:36:20 PDT
Comment on attachment 197501 [details] [diff] [review]
Patch

Boris, sorry but I am to lame to get these things fixed in a timely manner.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2005-09-27 06:30:35 PDT
Fixed on trunk.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2005-09-27 06:32:12 PDT
Comment on attachment 197501 [details] [diff] [review]
Patch

Requesting 1.8b5 approval.  This just fixes a regression by backing out part of
a patch...  It's not great, but the best we can do in the 1.8 timeframe at this
point, I think.

Note You need to log in before you can comment on or make changes to this bug.