Last Comment Bug 310335 - Build fails on xptcinvoke_arm.cpp:139: error: extra ';'
: Build fails on xptcinvoke_arm.cpp:139: error: extra ';'
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: 1.0 Branch
: Other Linux
: -- normal (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
Mentors:
http://experimental.debian.net/fetch....
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 11:12 PDT by micah
Modified: 2005-10-13 14:34 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch, for review (959 bytes, patch)
2005-10-13 10:44 PDT, Benjamin Smedberg [:bsmedberg]
dougt: review+
asa: approval1.8rc1+
Details | Diff | Review

Description micah 2005-09-28 11:12:38 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050802 Galeon/1.3.21 (Debian package 1.3.21-6)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050802 Galeon/1.3.21 (Debian package 1.3.21-6)

Build fails on xptcinvoke_arm.cpp:139: error: extra ';' due to newer gcc being
more strict about proper C++, see the build log here:
http://experimental.debian.net/fetch.php?&pkg=mozilla-thunderbird&ver=1.0.6-3etch2&arch=arm&stamp=1127923033&file=log&as=raw

Fix is:
diff -ur mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp.orig
mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
--- mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp.orig  
2005-09-28 13:14:42.380985261 -0400
+++ mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp       
2005-09-28 13:15:13.882233614 -0400
@@ -136,7 +136,7 @@
         PRUint32 fn_count;     
         PRUint32 fn_copy;      
     };
-};
+}
 
 XPTC_PUBLIC_API(nsresult)
 XPTC_InvokeByIndex(nsISupports* that, PRUint32 methodIndex,


Reproducible: Always

Steps to Reproduce:
1. Compile thunderbird 1.0.6 or later on the arm architecture
2. Wait

Actual Results:  
Build fails with the error:
make[8]: Entering directory
`/build/buildd/mozilla-thunderbird-1.0.6/build-dir/mozilla/xpcom/reflect/xptcall/src/md/unix'
xptcinvoke_arm.cpp
c++ -o xptcinvoke_arm.o -c -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\"
-DEXPORT_XPTC_API   -I../../../../../../dist/include/xpcom
-I../../../../../../dist/include
-I/build/buildd/mozilla-thunderbird-1.0.6/build-dir/mozilla/dist/include/nspr  
 -I/usr/include -I./../..    -fPIC   -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2 -O2   -DMOZILLA_CLIENT
-include ../../../../../../mozilla-config.h -Wp,-MD,.deps/xptcinvoke_arm.pp
xptcinvoke_arm.cpp
xptcinvoke_arm.cpp:139: error: extra ';'
make[8]: *** [xptcinvoke_arm.o] Error 1

See full build log:
http://experimental.debian.net/fetch.php?&pkg=mozilla-thunderbird&ver=1.0.6-3etch2&arch=arm&stamp=1127923033&file=log&as=raw

Expected Results:  
Should compile properly

Full build log is here: 

http://experimental.debian.net/fetch.php?&pkg=mozilla-thunderbird&ver=1.0.6-3etch2&arch=arm&stamp=1127923033&file=log&as=raw
Comment 1 Benjamin Smedberg [:bsmedberg] 2005-10-13 10:44:36 PDT
Created attachment 199438 [details] [diff] [review]
Patch, for review
Comment 2 Doug Turner (:dougt) 2005-10-13 10:46:53 PDT
Comment on attachment 199438 [details] [diff] [review]
Patch, for review

this works for me without the patch (using OE to build), but the patch seams
fine.
Comment 3 Benjamin Smedberg [:bsmedberg] 2005-10-13 14:34:02 PDT
Fixed, trunk and 1.8 branch.

Note You need to log in before you can comment on or make changes to this bug.