Rio MP3 player page looks bad in mozilla

VERIFIED DUPLICATE of bug 29370

Status

P3
normal
VERIFIED DUPLICATE of bug 29370
19 years ago
14 years ago

People

(Reporter: phil, Assigned: cbegle)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using 3/7 build on Windows NT

Go to http://www.riohome.com

Notice that text beginning "Mix your own music..." appears black. It appears
white using Navigator 4.7. Looking at the page source, they seem to be doing a
lot of stuff based on browser capabilities.

cc'ing rickg and ekrock for further analysis

Comment 1

19 years ago
There is a table problem with the borders around the rio 500 and rio 300 links,
which I filed as bug 31055.  The text should be white:
The style sheet says

TD { COLOR: white; FONT-FAMILY: Arial; FONT-SIZE: 9pt; PADDING-LEFT: 0pt }

And the text is in a table cell:

<td width="325">  Mix your own music ....</td>

I think the browser sniffing stuff is a red herring.  As far as I can see, that
JS code is not used at all on the page.  I actually saw the text display white,
and on reload it turned to black.  Someone filed a bug on style sheets not being
active when the page is reloaded....
(Reporter)

Comment 2

19 years ago
So, would you call this a table bug or a style bug? Just to help reassign to the
right person...

Comment 3

19 years ago
I see the text perfectly on NT. This may have been fixed by a residual style bug 
that was fixed yesterday. (There is also a layout bug on this page, but it's 
minor.)

Comment 4

19 years ago
I think this is a network bug.  I filed a separate bug 31060, mark duplicate if
you agree that this is the issue.  Do you see any other problems on this site,
phil?
(Reporter)

Comment 5

19 years ago
RickG, in today's build, the text looks better, but not perfect. Example: once
on the home page, click on the Rio 500 link. That page has the text "The Rio 500
puts the power..." in black, rather than white, as in 4.72. But the other
paragraphs are now white, rather than black as in yesterday's build.

Richard, I don't really know enough to evaluate whether this is a dup of 31060
or not. If someone who was more expert than me in debugging browser content
issues marked it a dup, I wouldn't complain. But I would watch bug 29370 to make
sure this symptom went away when 29370 gets fixed...

Comment 6

19 years ago
They turned off caching for CSS and JS, and the page looks good to me in Linux
build 2000.03.09.13.  What about you, Phil?
(Reporter)

Comment 7

19 years ago
Yep, the page looks fine in the 03-09-14 build. Marking a dup.


*** This bug has been marked as a duplicate of 29370 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 8

19 years ago
verifed dupe of now opened bug
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.