cursor of input field disappears if on top of an absolute positioned div with overflow auto

RESOLVED DUPLICATE of bug 167801

Status

()

defect
RESOLVED DUPLICATE of bug 167801
14 years ago
14 years ago

People

(Reporter: ivanvriezen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050914 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050914 Firefox/1.6a1

testcase:
http://download.team-fonzie.net/~hautis/bugs/overflowauto_cursor.htmle

If a text input is placed on top of an absolute positioned div, the text cursor
functions properly, as shown in the right example.
However, if the div style is set to "overflow:auto", the cursor is not visible
anymore, as shown in the left example.

Reproducible: Always

Steps to Reproduce:
1. Go to http://download.team-fonzie.net/~hautis/bugs/overflowauto_cursor.html
2. Select the left text input field.
3. Move the cursor on top of the yellow block using the arrow keys.

Actual Results:  
The text cursor disappears.

Expected Results:  
Show the text cursor.
Reporter

Comment 1

14 years ago
Somehow the character e got after the testcase url, should instead be:
http://download.team-fonzie.net/~hautis/bugs/overflowauto_cursor.html

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 167801 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.