Closed Bug 310760 Opened 15 years ago Closed 15 years ago

menu can't get the input chars when my chinese input is on with english input status

Categories

(Firefox :: Keyboard Navigation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 55751

People

(Reporter: spectertech, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

mozilla suite can't get the uparrow & downarrow in URL bar when my chinese input
is on firefox has improved this. but when I use Alt+T to enter the tools menu
then I want to use shortcut "O" to set up my options, the menu keeps there not
invoking the options dialog. I use microsoft pinyin input method to input
chinese I have used shift key to changed to english input status, therefore 'o'
should be captured  by firefox. than the shortcut should work. At this status I
use alt+o can invoke the options dialog, that's very strange, alt key should not
be required? IE doesn't have that problem. When I use IE, I can invoke the menu
& use short cut key inside these menus correctly even if my chinese input method
not switch to english input status. Now I don't hope firefox can do so, but I
think firefox should get the shortcut key just like 'o' correctly to invoke
options dialog.

Reproducible: Always

Steps to Reproduce:
1.have microsoft pinyin input method on
2.switch to english input method by click "shift" key in the keyboard
3.then Alt+T to enter Tools menu for example
4.use accelerating key 'o' to invoke options dialog


Actual Results:  
nothing happened. the Tools menu still there, options dialog hasn't been shown.
but if I press "Alt+O"or "Ctrl+O",the options dialog shown at once.

Expected Results:  
when I have my microsoft pinyin input method on & switch to english input
status, I shall use 'o' accelerating key to invoke options dialog not 'Alt+o' or
'ctrl+o'
I think that's because alt or ctrl key can let the microsoft pinyin input method
go to the suitable status(sending out this key to firefox) for firefox's menu
capturing keys. But IE can do this correctly, I hope firefox can do so.
It seems this bug is not happened in windows 2003
But not everybody want to upgrade their system.

*** This bug has been marked as a duplicate of 55751 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.