Closed Bug 310877 Opened 15 years ago Closed 15 years ago

nbsps in form inputs changed to regular spaces when form is displayed

Categories

(Core :: DOM: HTML Parser, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 218277

People

(Reporter: pawlowski, Assigned: mrbkap)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/312.5.1 (KHTML, like Gecko) Safari/312.3.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915

If the HTML contains a form input containing an nbsp, when that form input is displayed by the browser 
it contains a regular space instead.

Reproducible: Always

Steps to Reproduce:
1. Go to this URL: http://scooter.webservepro.com/~pnp/formsubmit.html
2. If you look at the HTML source, you can see that both the text input and the textarea contain an nbsp
3. When you submit the form in Firefox, take a look at the URL -- both nbsps are submitted as "+" 
(plain space). 

Actual Results:  
This is the easiest way to see the problem, which is that the text inputs displayed by the browser 
contain actual regular spaces and not nbsps.


Expected Results:  
Try the provided form in IE or Safari, and you can see the very different behavior (the proper %C2%A0 
value encoded in the URL).

I believe this must be relatively new. Our software relies on the assumption that if you put something in 
a textarea and then submit it, you get the same thing back. We have only run into this problem 
recently, so I'm inclined to think that it didn't exist before.

*** This bug has been marked as a duplicate of 218277 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.