use X cursor theme for more cursors

RESOLVED FIXED in mozilla30

Status

()

Core
Widget: Gtk
RESOLVED FIXED
13 years ago
4 years ago

People

(Reporter: Christian Persch (GNOME) (away; not receiving bug mail), Assigned: flying sheep)

Tracking

(Blocks: 1 bug)

Trunk
mozilla30
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

While the gtk2 widget code makes use of some themeable cursors (those available
in stock gtk2 with gdk_cursor_new), it only uses its builtin images for some
other cursors, like "help" and "copy", which may be available in the X cursor
theme and be used with gdk_cursor_new_from_name.
Created attachment 198308 [details] [diff] [review]
first patch

The patch still has some shortcoming:
- themed gdkcursors automatically update themselves when the theme changes.
However in case the previous theme didn't have the cursor and therefore we used
our builtin pixmap, this update does not happen (until the next start, of
course)
- gdk_cursor_new_from_name is only available in gdk 2.8 and the patch uses it
unconditionally. Probably needs to resort to the usual dynamic lib stuff :(
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
*** Bug 336665 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

8 years ago
check out my patch idea on https://bugzilla.mozilla.org/show_bug.cgi?id=609889#c11
Duplicate of this bug: 609889
(Assignee)

Comment 5

5 years ago
people, what’s going on? GTK 2.8 is now several years old, time to simply unconditionally depend on it and fix this.
(Assignee)

Comment 7

4 years ago
Created attachment 8377517 [details] [diff] [review]
cursors.patch

so, i hope someone sees this.

i did it. all cursors (except the zoom ones) now work with GNOME’s default theme DMZ, and all cursors except the crosshair work in KDE (which is a bug there: https://github.com/ruphy/oxy-cursors/issues/2 and https://bugs.kde.org/show_bug.cgi?id=290356)

Updated

4 years ago
Attachment #8377517 - Flags: review?(karlt)
Attachment #8377517 - Flags: review?(karlt) → review+

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 8

4 years ago
Created attachment 8378172 [details] [diff] [review]
cursors.patch

updated patch with author and stuff
Attachment #8377517 - Attachment is obsolete: true

Updated

4 years ago
Attachment #198308 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/068ed8d0e7c2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30

Updated

4 years ago
Assignee: blizzard → flying-sheep

Updated

4 years ago
Depends on: 1025616
You need to log in before you can comment on or make changes to this bug.