The default bug view has changed. See this FAQ.

label bound to model doesn't work for choices inside of select

RESOLVED FIXED

Status

Core Graveyard
XForms
RESOLVED FIXED
12 years ago
9 months ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

({fixed1.8})

Trunk
fixed1.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

1.40 KB, application/xhtml+xml
Details
1.42 KB, patch
Allan Beaufour
: review+
Doron Rosenberg (IBM)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

<xf:select ref="/example/select">
  <xf:label>Flavors</xf:label>
  <xf:choices>
    <!-- You cannot see the label -->
    <xf:label ref="/example/label"/>
    <xf:item>
      <xf:label ref="/example/label"/>
      <xf:value>v</xf:value>
  </xf:choices>
</xf:select>

It is true for <select appearance="compact"/> and <select appearance="full"/>.

Error code lines:

http://lxr.mozilla.org/mozilla/source/extensions/xforms/resources/content/select.xml#334
http://lxr.mozilla.org/mozilla/source/extensions/xforms/resources/content/select.xml#645

Reproducible: Always
(Assignee)

Comment 1

12 years ago
For bug fixing label control can realize textValue property like it proposes
nsIXFormsLabelElement interface.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: label binded to model doesn't work for choises inside of select → label bound to model doesn't work for choices inside of select

Comment 2

12 years ago
Created attachment 198419 [details]
Testcase
(Assignee)

Comment 3

12 years ago
Created attachment 198423 [details] [diff] [review]
patch
Attachment #198423 - Flags: review?(allan)
(Assignee)

Comment 4

12 years ago
Created attachment 198424 [details] [diff] [review]
patch
Attachment #198423 - Attachment is obsolete: true
Attachment #198424 - Flags: review?(allan)

Updated

12 years ago
Assignee: aaronr → surkov
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Updated

12 years ago
Attachment #198423 - Flags: review?(allan)

Comment 5

12 years ago
Comment on attachment 198424 [details] [diff] [review]
patch

Seems like a good plan to clone them instead. But I do not know if there was a
reason for not to. Doron'll answer that I guess :)

r=me
Attachment #198424 - Flags: review?(doronr)
Attachment #198424 - Flags: review?(allan)
Attachment #198424 - Flags: review+
(Assignee)

Comment 6

12 years ago
Label can contain arbitrary tags. If label will be cloned then choice label can
have custom look. For example:

<xf:choices>
    <xf:label><span style="color: blue">It's a label</span></xf:label>
    <xf:item

Updated

12 years ago
Attachment #198424 - Flags: review?(doronr) → review+

Comment 7

12 years ago
checked into trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch

Comment 8

12 years ago
Reopening bug since the patch hasn't been checked into the branch, yet.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

12 years ago
checked into branch.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Whiteboard: xf-to-branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.