Closed Bug 311039 Opened 15 years ago Closed 15 years ago

css for selection

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Linux
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 176170

People

(Reporter: pch, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

when styling the selection an error message is printed to the js console "Error:
Expected pseudo-element but found 'selection'.  Ruleset ignored due to bad
selector. Source File: http://www.kunstnetztirol.at/jss/table-all.css
Line: 33" - while the rule still applies.

Reproducible: Always

Steps to Reproduce:
1. open http://www.kunstnetztirol.at/knt/
2. read css error in js console
3. select text and see the style applied

Actual Results:  
actual results are ok.

Expected Results:  
no error printed

http://www.w3.org/TR/2001/CR-css3-selectors-20011113/#UIfragments
oops, possibly, the style still applies because of the preceding
"-moz-selection" selector in the style sheet...
It's ignored because it's so far only impelemented as -moz-selection. That one
works. Just selection not yet.

*** This bug has been marked as a duplicate of 65133 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 176170 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago15 years ago
Component: General → Style System (CSS)
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.