Cannot put focus into text field in popup window

RESOLVED FIXED in Camino1.0

Status

P2
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: neilio, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
macOS
fixed1.8

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051002 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051002 Camino/1.0+

It's impossible to put focus into a text field in a popup window. The only way
to work around this is to resize the window (if it's resizable) and then you can
put focus into the text field.

Regression from the recent missing caret bug fixes?

Reproducible: Always

Steps to Reproduce:
1. Go to the cited URL test case
2. Click on the link
3. Try to put focus into the textarea in the popup window
(Assignee)

Comment 1

14 years ago
Confirmed using trunk nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

14 years ago
Priority: -- → P2
Target Milestone: --- → Camino1.0
Can't reproduce on the 10/4 branch build.
(Assignee)

Comment 3

14 years ago
Regression from bug 297343.
Assignee: mikepinkerton → sfraser_bugs
Depends on: 297343
(Assignee)

Comment 4

14 years ago
Posted patch PatchSplinter Review
So we do have to call -setBrowserActive: in the Camino code after all, for
cases where the window is created before the views. As in widget, we do this
after a brief delay so that when we get back into SetFocus(), the window state
is good.
(Assignee)

Comment 5

14 years ago
Fixed on trunk (and landed along with branch fix for bug 297343).
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.