Last Comment Bug 311063 - Bogus assertions, and tspan attributes x/y/dx/dy aren't live
: Bogus assertions, and tspan attributes x/y/dx/dy aren't live
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: tor
: Hixie (not reading bugmail)
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 08:10 PDT by Jonathan Watt [:jwatt]
Modified: 2006-11-15 06:59 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (690 bytes, image/svg+xml)
2005-10-04 08:15 PDT, Jonathan Watt [:jwatt]
no flags Details
live tspan x/y/dx/dy (3.27 KB, patch)
2005-10-04 09:17 PDT, tor
no flags Details | Diff | Splinter Review
add null checks (3.70 KB, patch)
2005-10-04 09:43 PDT, tor
alex: review+
asa: approval1.8rc1-
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] 2005-10-04 08:10:27 PDT
 
Comment 1 Jonathan Watt [:jwatt] 2005-10-04 08:15:57 PDT
Created attachment 198451 [details]
testcase

We have two problems. First, we're throwing bogus assertions during
construction and destruction of tspan elements if they don't have an x or a y
attribute. Second, the x/y/dx/dy attributes aren't live on tspan. This testcase
demonstrates both these problems.

The reason we're throwing assertions is because in nsSVGTSpanFrame::Init() and
nsSVGTSpanFrame::~nsSVGTSpanFrame() GetY is returning nsnull. As a result
NS_ADD_SVGVALUE_OBSERVER and NS_REMOVE_SVGVALUE_OBSERVER assert.
Comment 2 tor 2005-10-04 09:17:15 PDT
Created attachment 198456 [details] [diff] [review]
live tspan x/y/dx/dy
Comment 3 tor 2005-10-04 09:43:52 PDT
Created attachment 198461 [details] [diff] [review]
add null checks
Comment 4 Alex Fritze 2005-10-10 13:25:21 PDT
Comment on attachment 198461 [details] [diff] [review]
add null checks

r=afri
Comment 5 tor 2005-10-10 14:19:03 PDT
Checked in on trunk.
Comment 6 tor 2005-10-10 14:19:53 PDT
Comment on attachment 198461 [details] [diff] [review]
add null checks

DOM compliance issue, low risk.
Comment 7 Asa Dotzler [:asa] 2005-10-10 15:39:48 PDT
Comment on attachment 198461 [details] [diff] [review]
add null checks

too late for non-critical changes.

Note You need to log in before you can comment on or make changes to this bug.