treat <! as the start of a comment to end of line, unless e4x=1 (was: page keeps reloading)

RESOLVED FIXED in mozilla1.8beta5

Status

()

Core
JavaScript Engine
P1
blocker
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Peter6, Assigned: brendan)

Tracking

({fixed1.8, regression})

Trunk
mozilla1.8beta5
fixed1.8, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051004
Firefox/1.4.1 ID:2005100402

after patch Bug 310993 landed the url above keeps reloading

works in 20051003 2217pdt build
fails in 20051004 0252pdt build
(Reporter)

Updated

12 years ago
Flags: blocking1.8b5?
(Reporter)

Comment 1

12 years ago
same regressionrange
http://maps.google.com/ doesn't work anymore
(Reporter)

Updated

12 years ago
Summary: page keeps reloading → page keeps reloading / maps.google.com broken

Comment 2

12 years ago
https://riteaid.rebateplus.com/RebateListPage.asp?categories=20
check box next to, let's say razor and click add to list - doesn't work anymore
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051004
Firefox/1.4.1 ID:2005100405

worked fine on 20051003
(Assignee)

Updated

12 years ago
Assignee: nobody → brendan
Depends on: 310993
Flags: blocking1.8b5? → blocking1.8b5+
(Assignee)

Updated

12 years ago
No longer depends on: 310993
(Assignee)

Updated

12 years ago
Depends on: 310993
comment 2 is a different bug, caused by bug 310351. I'll open a new bug to fix it.
(Assignee)

Comment 4

12 years ago
Hrm, maps.google.com works for me still with an updated js/src and an older tree
(I am testing js changes in isolation from other recent Gecko, etc., changes). 
Peter, what doesn't work for you?  The maps.google.com problem should be filed
separately.

The riteaid URL and reproduce-by steps in comment 2 work for me, so I suspect
that's a separate issue too.

Patch in a minute for the problem affecting this bug's URL.

/be
Component: General → JavaScript Engine
Product: Firefox → Core
Target Milestone: --- → mozilla1.8beta5
Version: 1.5 Branch → Trunk
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Priority: -- → P1
Hardware: PC → All
(Assignee)

Comment 5

12 years ago
Created attachment 198475 [details] [diff] [review]
treat <! as the start of a comment to end of line, unless e4x=1

I feel like Bart Simpson, writing "I will respect backward compatibility
authority" 100 times on the blackboard.

/be
Attachment #198475 - Flags: review?(mrbkap)
Attachment #198475 - Flags: approval1.8b5?
(Assignee)

Updated

12 years ago
Summary: page keeps reloading / maps.google.com broken → page keeps reloading
(Reporter)

Comment 6

12 years ago
(In reply to comment #4)
> Hrm, maps.google.com works for me still with an updated js/src and an older tree
> (I am testing js changes in isolation from other recent Gecko, etc., changes). 
> Peter, what doesn't work for you?  The maps.google.com problem should be filed
> separately.

> /be

It just gives a gray empty screen where the map should be (confirmed by many)
(Assignee)

Comment 7

12 years ago
(In reply to comment #6)
> It just gives a gray empty screen where the map should be (confirmed by many)

I believe you, and I said so -- it's just not due to the patch that regressed
this bug's URL, which was the patch for bug 310993.  I can prove that by backing
out that patch and fixing this bug, in my tree with an older Gecko but up to
date JS engine source.  In my tree, maps.google.com works fine with or without
the patch for bug 310993.  So the maps.google.com regression is due to a non-JS
change.

This bug is fixed by the attached patch.

/be
Comment on attachment 198475 [details] [diff] [review]
treat <! as the start of a comment to end of line, unless e4x=1

I still want my t-shirt. r=mrbkap
Attachment #198475 - Flags: review?(mrbkap) → review+
(Reporter)

Comment 9

12 years ago
I filed Bug 311094 for maps.google.com

Comment 10

12 years ago
Comment on attachment 198475 [details] [diff] [review]
treat <! as the start of a comment to end of line, unless e4x=1

mike can you give us an extra level of review here since we may spin the
release for this. Extra eyes is always good.
Attachment #198475 - Flags: superreview?(shaver)
Comment on attachment 198475 [details] [diff] [review]
treat <! as the start of a comment to end of line, unless e4x=1

sr=shaver
Attachment #198475 - Flags: superreview?(shaver) → superreview+
Comment on attachment 198475 [details] [diff] [review]
treat <! as the start of a comment to end of line, unless e4x=1

approving based on mscott's email that said this was blocking the respin
Attachment #198475 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Comment 13

12 years ago
Fixed on branch and trunk.

/be
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
(Reporter)

Comment 14

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051004
Firefox/1.4.1 ID:2005100415

Verified on win

Comment 15

12 years ago
Please check also wto.int menu
(Assignee)

Comment 16

12 years ago
(In reply to comment #15)
> Please check also wto.int menu

Eh?

/be

Comment 17

12 years ago
I assume comment 15 has something to do with http://www.wto.int/.

Updated

12 years ago
Summary: page keeps reloading → treat <! as the start of a comment to end of line, unless e4x=1 (was: page keeps reloading)

Comment 18

12 years ago
Checking in regress-311071.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-311071.js,v  <--  regress-311071.js
initial revision: 1.1
done
Flags: testcase+
Depends on: 311950
This causes JS_ASSERT failures and ensuing crashes -- see bug 311950.
Depends on: 375406
You need to log in before you can comment on or make changes to this bug.