Closed Bug 311296 Opened 17 years ago Closed 17 years ago

Deleted event re-appears unless calendar is reloaded prior to deleting a different event

Categories

(Calendar :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 287612

People

(Reporter: peligro_rice, Assigned: mostafah)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I have tested this between the mozilla extension and the sunbird stand alone. If
I add/delete an event from one it seems to delete/add. However if I open the
other program I still see the deleted event, don't see the added(no suprise
there). If I reload the calendar then the event disappears/appears (again, no
suprise). However if I delete a separate event, before reloading the calendar,
the event that was deleted/added in the other program is still there/gone, and
if reloaded on the other program the deleted event re-appears.

My guess is that when deleting an event the program does not reload the calendar
prior to sending the delete, like it does when you add an event.

Reproducible: Always

Steps to Reproduce:
1.Subscribe to remote calendar, click to automatically publish your changes to
the remote calendar.
2. On another machine/extension: Subscribe to the same remote calendar, click to
automatically publish your changes to the remote calendar.
2. Create two events on the remote calendar on machine 1.
3. Reload the remote calendar on both machines.
4. Delete event A on the remote calendar from machine 1(it will appear deleted
locally)
5. View the calendar from machine 2 (without reloading)
6. Delete event B from the calendar from machine 2
7. Reload the calendar on machine 1
Actual Results:  
The deleted event re-appeared on machine 1

Expected Results:  
The deleted event should have been deleted

I think that when deleting the progam sends the local calendar file to the
server prior to deleting the event.

If the program were to retrieve the calendar from the server prior to deleting
the event that this issue would be resolved.
Duping against bug 287612.  Reporter, if you disagree, you may reopen this bug.

*** This bug has been marked as a duplicate of 287612 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Please re-open this bug is not fixed on 20060821 Windows XP installer build.

When creating an event, a reoccuring event or not. You can delete the event. But if you right click the cell in the calendar you can still edit it... it is not until you restart calendar that it goes away.
You need to log in before you can comment on or make changes to this bug.