Last Comment Bug 311460 - Accevent failing for options in closed combo box
: Accevent failing for options in closed combo box
Status: RESOLVED FIXED
: access, fixed1.8, regression, sec508
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 23:17 PDT by Aaron Leventhal
Modified: 2005-10-10 19:07 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Allow option and optgroup accessibles to be created inside hidden views (1.31 KB, patch)
2005-10-06 23:21 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
Reverse AreAncestorViewsVisible() condition for creating accessibles added in bug 309329 (856 bytes, patch)
2005-10-07 00:22 PDT, Aaron Leventhal
parente: review+
jst: superreview+
asa: approval1.8rc1+
Details | Diff | Splinter Review

Description Aaron Leventhal 2005-10-06 23:17:36 PDT
Since the checkin for bug 309329 we no longer create accessibles for objects in
hidden views.

The problem in that combo box options can be in a hidden view when you are
arrowing through a closed list.

So, we need to be able create accessibles for options and optgroups whether the
listbox they are in is opened or closed.
Comment 1 Aaron Leventhal 2005-10-06 23:21:22 PDT
Created attachment 198781 [details] [diff] [review]
Allow option and optgroup accessibles to be created inside hidden views

Eventually we need to rethink how we deal with hidden stuff in web content, but
not for branch.
Comment 2 Aaron Leventhal 2005-10-07 00:22:06 PDT
Created attachment 198783 [details] [diff] [review]
Reverse AreAncestorViewsVisible() condition for creating accessibles added in bug 309329

This condition also caused bug 310377.
Comment 3 Johnny Stenback (:jst, jst@mozilla.com) 2005-10-07 16:18:26 PDT
Comment on attachment 198783 [details] [diff] [review]
Reverse AreAncestorViewsVisible() condition for creating accessibles added in bug 309329

sr=jst
Comment 4 Scott MacGregor 2005-10-10 16:23:38 PDT
asa approved this patch for the branch but it isn't a blocker. Would be great to
get in ASAP though.

Note You need to log in before you can comment on or make changes to this bug.