If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't drag and drop favicon or tab (in order to add it as a bookmark) below the last item in the bookmark sidebar

RESOLVED FIXED in Firefox 2 beta2

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Hari Kumar G, Assigned: Simon Bünzli)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 beta2
fixed1.8.1
Points:
---
Bug Flags:
blocking1.8rc1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051006
Firefox/1.6a1

Open the bookmarks panel.  Now drag any tab or url icon from location bar to the
panel.  The bookmark could be added to any of the folders in the bookmarks list
but not to the root (to be shown directly under the bookmarks menu)  If
attempted through the Add bookmark dialog this is possible and shows up in the
panel.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1 ID:2005100618

WFM in this build: 1.9a1_2005100623. 

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051006 Firefox/1.6a1

WFM on Linux as well
(Assignee)

Comment 3

12 years ago
I know this is a trunk bug, however there is some discrepancy on the branch as
well which might be related to this bug: dropping links from the content area in
the bookmarks sidebar works anywhere below the tree, whereas for dropping urls
from the urlbar/tabbar you must be no more than a few pixels below the last
visible item. I'm not sure whether you mean this behavior, but if you do this is
a usability issue for Firefox 1.5 as well (and probably and easily fixed one, so
please request blocking1.8rc1).
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> I know this is a trunk bug, however there is some discrepancy on the branch as
> well which might be related to this bug: dropping links from the content area 
in
> the bookmarks sidebar works anywhere below the tree, whereas for dropping urls
> from the urlbar/tabbar you must be no more than a few pixels below the last
> visible item. I'm not sure whether you mean this behavior, but if you do this 
is
> a usability issue for Firefox 1.5 as well (and probably and easily fixed one, 
so
> please request blocking1.8rc1).

oops! There was some mistake on my side in explaining the bug. 

What is said in comment no. 3 is the actual situation.  The user has to "place" 
the dragged item exactly below or between folders / other items.  There is no 
general 'drag'n'drop' functionality (which is mostly possible over a wide area 
in the drop-target.  This is to be made possible.

Comment 5

12 years ago
Dupe of bug 235243?
(Assignee)

Comment 6

12 years ago
Created attachment 198840 [details] [diff] [review]
Enable drag&drop for the tree, disable it for the sidebar

This patch adds full drag&drop support to the rest of the bookmarks tree. On
the other hand, it disables drag&drop for the sidebar, leaving it to its
content to do the handling (most sidebar content isn't able to do anything with
dropped URLs, so the wrong feedback given might just confuse the user). As far
as I can tell, the behavior should be correct, but I'm no drag&drop expert...
Attachment #198840 - Flags: review?(mconnor)
(Assignee)

Comment 7

12 years ago
Is it too late already for such non-obvious bugs?

(In reply to comment #5)
> Dupe of bug 235243?
No, this one is about the Bookmarks panel/sidebar.
Flags: blocking1.8rc1?
Comment on attachment 198840 [details] [diff] [review]
Enable drag&drop for the tree, disable it for the sidebar

there's no reason to disable dnd support in the sidebar because its not
perfect.  If we disable this people will flip, and rightly so.
Attachment #198840 - Flags: review?(mconnor) → review-
(Assignee)

Comment 9

12 years ago
(In reply to comment #8)
> (From update of attachment 198840 [details] [diff] [review] [edit])
> there's no reason to disable dnd support in the sidebar because its not
> perfect.  If we disable this people will flip, and rightly so.

It would obviously not be disabled completely, since right for the bookmarks
panel we need it as well. I'd just be disabled for all non-drag&drop aware
panels (such as the History panel [where BTW dragging is still supported as
you'd expect], the Downloads manager, the Error Console, etc.). My description
probably sounded harsher than it was intended. People probably wouldn't even
notice, since in the one other panel where drag&drop would make sense (the
webpanel) it doesn't work anyway.

However, if you don't like the idea at all, would you reconsider the second part
of the patch (concerning only bookmarksPanel.xul and bookmarksTree.xml)?
(Assignee)

Comment 10

12 years ago
Created attachment 198843 [details] [diff] [review]
just completely enable d&d for the bookmarks sidebar
Attachment #198843 - Flags: review?(mconnor)

Comment 11

12 years ago
Can someone please explain to me what's broken here and what we're fixing? This
bug appears to have morphed into something other than its description...
(Assignee)

Comment 12

12 years ago
Not at all. The bug consists in the fact that you can't drop any bookmarks or
tabs at the space more than two or three pixels below the last item in the
bookmarks tree in the sidebar panel. Since you can drop there links from the
content area and since it'd make such a nice big target, I'm enabling this area
as such.

Now, while trying to fix this, I noticed that the sidebar itself is actually a
drop-target for links/text originating from the content area. This might be
desirable for the bookmarks sidebar, is however at best confusing for most (if
not all) other sidebar panels. Since this would still work for this specific
panel, I'd suggest to at the same time switch off the drop-indicator where it
doesn't make sense.

Updated

12 years ago
Summary: can't drag and drop boomark into Bookmarks root folder → Can't drag and drop favicon or tab (in order to add it as a bookmark) below the last item in the bookmark sidebar

Updated

12 years ago
Attachment #198843 - Flags: review?(mconnor) → review+
check in on trunk:
Checking in bookmarksPanel.xul;
/cvsroot/mozilla/browser/components/bookmarks/content/bookmarksPanel.xul,v  <--
 bookmarksPanel.xul
new revision: 1.21; previous revision: 1.20
done
Checking in bookmarksTree.xml;
/cvsroot/mozilla/browser/components/bookmarks/content/bookmarksTree.xml,v  <-- 
bookmarksTree.xml
new revision: 1.70; previous revision: 1.69
done
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: nobody → zeniko
Status: REOPENED → NEW
OS: Windows 2000 → All
Hardware: PC → All
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Attachment #198843 - Flags: approval1.8rc1?

Updated

12 years ago
Attachment #198843 - Flags: approval1.8rc1? → approval1.8rc1-

Updated

12 years ago
Flags: blocking1.8rc1? → blocking1.8rc1-

Updated

12 years ago
Flags: blocking1.8.1?
Is this worth checking in on the branch for b2?
(Assignee)

Updated

11 years ago
Attachment #198843 - Flags: approval1.8.1?
Comment on attachment 198843 [details] [diff] [review]
just completely enable d&d for the bookmarks sidebar

a=mconnor on behalf of drivers
Attachment #198843 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

11 years ago
Whiteboard: [checkin needed (1.8.1 branch)]
mozilla/browser/components/bookmarks/content/bookmarksPanel.xul 	1.18.10.4
mozilla/browser/components/bookmarks/content/bookmarksTree.xml 	1.68.2.7
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8.1 branch)]
Target Milestone: --- → Firefox 2 beta2
Version: Trunk → 2.0 Branch
You need to log in before you can comment on or make changes to this bug.