International characters in URI

RESOLVED DUPLICATE of bug 284474

Status

()

--
major
RESOLVED DUPLICATE of bug 284474
13 years ago
13 years ago

People

(Reporter: tomas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

I'm trying så fetch a page which contains swedish characters (ä and ö). As these
are in the URI, Firefox translates them to a %-representation. However, this
translation is wrong if I compare to what Safari and Opera does. Or I should
perhaps say the translation is "not the same" which results in the page isn't shown.




Reproducible: Always

Steps to Reproduce:
1. Go to the URL mentionen above
2. Klick on green banner where it says "Lövsättra 18hål"

The translation is done as follows:

Firefox:
http://www4.golf.se/huvudgk/index.asp?bana=L%C3%B6vs%C3%A4ttra&winwidth=1280

Safari and Opera:
http://www4.golf.se/huvudgk/index.asp?bana=L%F6vs%E4ttra&winwidth=1280

According to http://www.unicode.org/charts/PDF/U0080.pdf "ö" = F6, "ä" = E4
which is what Safari and Opera is using. Firefox isn't.

*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.