HTTP-EQUIV Refresh broken

VERIFIED WONTFIX

Status

()

Core
Networking
P3
normal
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: Bob Kaiser, Assigned: ruslan)

Tracking

Trunk
All
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-], URL)

(Reporter)

Description

19 years ago
The refresh (and auto-refresh) continue to display the original page shown when
it was opened.  No updates are displayed on refresh.  Have memory cache and disk
cache turned on in Edit / Preferences / Debug.  This same page refreshes and
auto-refreshes normally in Netscape 4.72.
Note: Bugzilla is reporting M13 when this browser is actually M14.
I can confirm this as a problem using W95 M14. Having searched Bugzilla, it 
seems there is a problem with Refresh HTTP headers, but HTTP-EQUIV meta tags are 
not flagged anywhere as broken...

I also have no idea what component this lives in, so I'm just going to confirm 
it and hope someone else knows :-)

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
Networking?  
Assignee: cbegle → gagan
Component: Browser-General → Networking
QA Contact: asadotzler → tever

Comment 3

19 years ago
Here is their HTML header-

<head>
   <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
   <meta http-equiv="Pragma" content="no-cache">
   <meta http-equiv="refresh" content="120">
   <meta name="keywords" content="Houston, traffic, map, freeway, speed">
   <meta name="description" content="The Houston Real-Time Traffic Map">
   <meta name="GENERATOR" content="Mozilla/4.61 [en] (WinNT; I) [Netscape]">
   <title>Houston Real-Time Traffic Map</title>
</head>

Looks like a problem with HTTP-EQUIV refreshes... jud?
Assignee: gagan → valeski
Summary: Refresh broken → HTTP-EQUIV Refresh broken

Comment 4

19 years ago
the refresh is occuring just fine. looks like we're not honoring some caching 
header or something. the images are supposed to reload but don't.
Assignee: valeski → gordon

Comment 5

18 years ago
Should this go to Neeti?
Target Milestone: --- → M16

Comment 6

18 years ago
Moving to M17 which is now considered part of beta2.
Target Milestone: M16 → M17

Updated

18 years ago
Keywords: beta2
Whiteboard: 1d

Updated

18 years ago
Keywords: nsbeta2

Comment 7

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: 1d → [nsbeta2+]1d
*** Bug 34524 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Ruslan, do you want this or should I deal with it?
(Assignee)

Comment 10

18 years ago
Up to you. Looks like we're not honoring pragma no-cache header and since this 
business is done somewhere inside of layout - the fix will amount to changing 
Refresh method in docshell to take an additional parameter to prohibit caching.
(Assignee)

Comment 11

18 years ago
Reassigning to myself since I started to work on refresh problems anyway
Assignee: gordon → ruslan
(Assignee)

Comment 12

18 years ago
Ok. Here's the deal. Strictly according to HTML spec, http-equiv is for the 
server-side use. It has not been the case, as us and IE were implementing 
refresh since a long time ago. If we were to adopt this extended interpretation 
- we would have to honor ALL http response headers in META tags, including 
cookies. It can certainly be done, but the changes will be kind of extensive in 
my mind. We can try though. Here's what HTML spec says:

"
The http-equiv attribute can be used in place of the name attribute and has a 
special significance when documents are
         retrieved via the Hypertext Transfer Protocol (HTTP). HTTP servers may 
use the property name specified by the http-equiv
         attribute to create an [RFC822]-style header in the HTTP response.

Note. Some user agents support the use of META to refresh the current page after 
a specified number of seconds,
           with the option of replacing it by a different URI. Authors should 
not use this technique to forward users to different
           pages, as this makes the page inaccessible to some users. Instead, 
automatic page forwarding should be done
           using server-side redirects.
"
Adding gagan to CC-list
Status: NEW → ASSIGNED
(Assignee)

Comment 13

18 years ago
Ok. I made refresh to do force-reload, which takes care of this specific case.
The more generic problem is whether to and how to honor generic http-equiv
headers needs further investigation. Removing nsbeta2 and moving to the future.
Hardware: PC → All
Whiteboard: [nsbeta2+]1d
Target Milestone: M17 → M20

Comment 14

18 years ago
Putting on beta2-minus notation, per request from Ruslan.  This is not a 
critical bug, and we have a ton of stuff for PR2.
Whiteboard: [nsbeta2-]

Comment 15

18 years ago
It looks like bug 3248, "HTTP headers are not passed on to main NGLayout code",
M18, is relevant to the remaining issues in this bug.
(Assignee)

Comment 16

18 years ago
Ok. No need to fix this - it's ok the way it is. Everything else is another 
dubious feature.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Comment 17

18 years ago
verified Wontfix
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.