checksetup.pl fails to compare versions of perl modules correctly

RESOLVED DUPLICATE of bug 257933

Status

()

Bugzilla
Installation & Upgrading
RESOLVED DUPLICATE of bug 257933
12 years ago
12 years ago

People

(Reporter: Philipp Zuderell, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When installing or upgrading Bugzilla, checksetup.pl sometimes fails to compare
the installed and required version of a perl module correctly. This seems always
to be the case when the version number of an installed module ends with a zero.
I ran into this during the fresh install of 2.18 several months ago und just
today during an upgrade from 2.18 to 2.20. I had File::Spec 0.90 installed, but
checksetup.pl complained that it needed at least 0.84 and found only 0.9
(missing zero). I then installed File::Spec 0.89 and it installed OK.

I hope this wasn't reported already as it seems so obvious, but I searched the
database for 20 min before I posted and couldn't find anything similar.

Reproducible: Always

Steps to Reproduce:
1. Install a perl module with a higher version than the one needed.
2. Module version number must end with zero (0.90 / 1.10 / ...).
3. Install or upgrade using checksetup.pl.

Actual Results:  
I was told to install a more recent module as mine wouldn't meet the
prerequisites, which is not true.

Expected Results:  
The skript should have determined the version of the installed module correctly
and thus should have noticed that it's higher than the minimum one. 0.9 != 0.90
(Reporter)

Comment 1

12 years ago
(In reply to comment #0)

> Steps to Reproduce:
> 1. Install a perl module with a higher version than the one needed.
> 2. Module version number must end with zero (0.90 / 1.10 / ...).

Number on first position must be the same than minimum required version. The
installed version without the trailing zero must be lower than the minimum
required version.

> 3. Install or upgrade using checksetup.pl.

Comment 2

12 years ago
You only see this problem with File::Spec, right? If yes, then this bug is a
dupe of bug 257933. If you see it with other modules as well, please reopen this
bug.

*** This bug has been marked as a duplicate of 257933 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
I can't remember what the module was when I ran into this problem for the first
time, probably it was File::Spec, too.
You need to log in before you can comment on or make changes to this bug.