A class with a reference member must have a user-defined constructor.

RESOLVED DUPLICATE of bug 311924

Status

Toolkit Graveyard
XULRunner
--
blocker
RESOLVED DUPLICATE of bug 311924
12 years ago
2 years ago

People

(Reporter: Iain MacDonnell, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8b4) Gecko/20050910 Firefox/1.4


Post fixes for bug 299992 (seemningly), can't build on Solaris with Sun Studio (10):

"/export/stuff/mozilla/ff15b2/mozilla/xpcom/glue/nsGREGlue.cpp", line 472:
Error: A class with a reference member must have a user-defined constructor.
"/export/stuff/mozilla/ff15b2/mozilla/xpcom/glue/nsGREGlue.cpp", line 523:
Error: Expected an expression.
"/export/stuff/mozilla/ff15b2/mozilla/xpcom/glue/nsGREGlue.cpp", line 529:
Error: Use ";" to terminate statements.3 Error(s) detected.
gmake[4]: *** [nsGREGlue.o] Error 3


Reproducible: Always
(Reporter)

Comment 1

12 years ago
Hrm, somehow I managed to submit this twice(!)

*** This bug has been marked as a duplicate of 311924 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.