Closed Bug 311958 Opened 15 years ago Closed 15 years ago

Update the nssckbi versions for NSS 3.11

Categories

(NSS :: Libraries, defect, P1)

3.11
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wtc, Assigned: wtc)

Details

Attachments

(1 file)

The nssckbi module version needs to be updated for
NSS 3.11.  We probably should also update its
"CryptokiVersion" to PKCS #11 v2.20.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → 3.11
Attached patch Proposed patchSplinter Review
Change the nssckbi version to 1.60.

Change the CryptokiVersion to 2.20.  I hope this is
what those xxx_CRYPTOKI_VERSION_xxx macros mean.
Attachment #199097 - Flags: review?(rrelyea)
Comment on attachment 199097 [details] [diff] [review]
Proposed patch

At some point we should probably add the missing attributes, though.
Attachment #199097 - Flags: review?(rrelyea) → review+
Patch checked in on the NSS trunk for NSS 3.11.

Checking in nssckbi.h;
/cvsroot/mozilla/security/nss/lib/ckfw/builtins/nssckbi.h,v  <--  nssckbi.h
new revision: 1.14; previous revision: 1.13
done
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.