Closed Bug 312007 Opened 16 years ago Closed 14 years ago

Tab Expose (Shiira Project)

Categories

(Camino Graveyard :: Tabbed Browsing, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 377248
Camino1.6

People

(Reporter: mozillabugs.3.maxchee, Assigned: mikepinkerton)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

A very innovative feature from the Shiira project. Tab Expose works just like
expose, but for tabs instead of windows. For more details, download Shiira from
their website.

Reproducible: Always
Summary: Tab Exposé (Shiira Porject) → Tab Exposé (Shiira Porject)
Summary: Tab Exposé (Shiira Porject) → Tab Exposé (Shiira Project)
yeah, i've had thoughts of this for over a year now.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Camino1.2
This is a neat feature addition but not a necessity IMO. On the other hand it would be very handy to use especialy when you have 10+ tabs opened at once. The question now is, should it open all tabs in all windows or just all tabs in the active window. I suppose the latter is more desirable.
While Shiira behaves like OSX expose by overlaying a tranlusent black color and showing the page contents on that. I really don't like that behaviour. I'd be much more in favour of an about:expose view that would tile all the tab contents in the app itself.
I saw this on Asa Dotzler's blog. Viamatic foXpose
https://addons.mozilla.org/extensions/moreinfo.php?id=1457&vid=7825
It seems Shiira's implementation of Tab Expose is also more sluggish than Apple's.
I really dislike the way Shiira does it. I'd lick the way that firefox extension and how IE7 do it.
I kind of perfer to see this feature implemented just like the F10 Expose. Except, instead of exposing every application window, it exposes every tab.
Bugzilla's searches aren't UTF-8 compliant :/ so tweaking summary so searches find this bug.
QA Contact: tabbed.browsing
Summary: Tab Exposé (Shiira Project) → Tab Expose (Shiira Project)
Is this still alive? This would be a great addition to Camino if it is.
Actually, I bet this bug should be either duped to bug 377248 or WONTFIXed in favor of that one. It's potentially different, potentially the same.
It's the same feature regardless of the exact implementation decisions; duping.

James, in the future please use the vote feature rather than commenting to indicate that you would like a feature implemented. There's no need to ask if a bug is alive, as the "Status" field indicates whether or not a bug has been closed.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377248
You need to log in before you can comment on or make changes to this bug.