Last Comment Bug 312009 - IMAP capability flags remembered across capability responses
: IMAP capability flags remembered across capability responses
Status: RESOLVED FIXED
: fixed1.8.0.4, fixed1.8.1
Product: MailNews Core
Classification: Components
Component: Networking: IMAP (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: ---
Assigned To: David :Bienvenu
: grylchan
Mentors:
: 317540 324138 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 22:40 PDT by Scott Talbot
Modified: 2009-01-22 10:17 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Forget capability flags. (702 bytes, patch)
2005-10-10 22:48 PDT, Scott Talbot
mozilla: review+
mozilla: superreview+
mozilla: approval‑branch‑1.8.1+
dveditz: approval1.8.0.4+
Details | Diff | Review

Description Scott Talbot 2005-10-10 22:40:24 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051011 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051011 SeaMonkey/1.1a

An IMAP server that I (would like to) connect to requires STARTTLS before login
so advertises logindisabled on connect (CAPABILITY IMAP4REV1 <stuff> STARTTLS
LOGINDISABLED), but after STARTTLS it doesn't advertise logindisabled and gives
some login types (CAPABILITY IMAP4REV1 <morestuff> AUTH=PLAIN AUTH=LOGIN).
Mozilla remembers the logindisabled so fails auth thinking that it's denied.

Reproducible: Always

Steps to Reproduce:
1. Connect to IMAP server that requires starttls.

Actual Results:  
Login failed.

Expected Results:  
Logged in.
Comment 1 Scott Talbot 2005-10-10 22:48:55 PDT
Created attachment 199140 [details] [diff] [review]
Forget capability flags.

capability_data() is called on every CAPABILITY response to parse flags out of
the capability so forget flags we know about and start afresh.
Comment 2 David :Bienvenu 2005-10-11 07:12:30 PDT
Comment on attachment 199140 [details] [diff] [review]
Forget capability flags.

thx, I thought I'd fixed this, but apparently not.
Comment 3 Scott Talbot 2005-10-12 14:25:00 PDT
I'm not a committer, could someone check this in for me?
Comment 4 David :Bienvenu 2005-10-18 10:44:12 PDT
fixed on trunk, thx.
Comment 5 David :Bienvenu 2005-11-23 08:06:39 PST
*** Bug 317540 has been marked as a duplicate of this bug. ***
Comment 6 David :Bienvenu 2006-02-02 18:19:47 PST
Comment on attachment 199140 [details] [diff] [review]
Forget capability flags.

we want this for the branch
Comment 7 Wolfgang Rosenauer [:wolfiR] 2006-04-25 13:04:15 PDT
Comment on attachment 199140 [details] [diff] [review]
Forget capability flags.

hmm, please consider to add this fix to 1.8.0 branch.
It bakes long enough on 1.8 and trunk, is simple and is kind of security related since it blocks using some secure methods of authentication.
Comment 8 Daniel Veditz [:dveditz] 2006-04-26 12:03:41 PDT
Comment on attachment 199140 [details] [diff] [review]
Forget capability flags.

approved for 1.8.0 branch, a=dveditz for drivers
Comment 9 Wolfgang Rosenauer [:wolfiR] 2006-04-27 03:55:31 PDT
checked in for 1.8.0 branch
Comment 10 David :Bienvenu 2006-08-22 13:59:39 PDT
*** Bug 324138 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.