If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash [@ QDPlatformGlobalToLocal()] (Flash plug-in, Mac)

VERIFIED DUPLICATE of bug 311399

Status

()

Firefox
Shell Integration
--
critical
VERIFIED DUPLICATE of bug 311399
12 years ago
6 years ago

People

(Reporter: Mark Mentovai, Assigned: Michelle Sintov)

Tracking

({crash, regression, topcrash})

1.5.0.x Branch
PowerPC
Mac OS X
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

12 years ago
This is showing up at the top of the Mac 1.5b2 Talkback list.  The Flash plugin
is on the stack right before QDPlatformGlobalToLocal().

http://talkback-public.mozilla.org/reports/firefox/FF15b2/smart-analysis.mac

It's also near the top of the 1.5b1 list (the two above it have been fixed:)

http://talkback-public.mozilla.org/reports/firefox/FF15b1/smart-analysis.mac

These crashes don't show up in alpha 2 or earlier.
(Reporter)

Updated

12 years ago
Summary: Crash [@ QDPlatformGlobalToLocal()] → Crash [@ QDPlatformGlobalToLocal()] (Flash plug-in, Mac)
(Assignee)

Comment 1

12 years ago
We (Flash Player team) will investigate.

This is a crash in the QuickDraw code. I believe the Flash Player is calling
GetMouse(), and QuickDraw is doing a global to local conversion of the
coordinates. Flash Player definitely might be doing something bad.

From the Talkback logs, this appears to be 10.4.2 only.

If you have a reproducible case of this please let me know. Thanks so much.
Assignee: nobody → msintov
(Reporter)

Comment 2

12 years ago
The bug only seemed like it only affected 10.4.2 because that was one of the few
releases for which I had uploaded the QD library to the talkback server.  We
also had the library from a virgin 10.3.9 installation, but not the updated
10.3.9 library that came with security update 2005-008.  I uploaded that library
on Tuesday evening.  Some of the crashes in QD.150.9.0 before then are
QDPlatformGlobalToLocal, and some are bug 311399 - you can tell which based on
the stacks.  The same goes for crashes in QD.96.3.0: I only uploaded the library
from 10.2.8, but there's apparently a significant installed base of some earlier
release out there.

Comment 3

12 years ago
I crash using FF 1.5 beta 2 and Camino 1.0a1 using Flash 8.0r22 on MacOSX 10.4.2
(Mac Mini), resolution 1024x768 millions of colors
Go to http://www.gamekult.com/advert01.html?goto=%2F&nopub=1
this is where I reliably crash: TB10397408Q TB10432999E TB10858210X
Not sure if it helps, my about:plugins lists both Flash 8.0r22 and 7.0r24...
And I've modified Flash settings to disallow third-party cookies:
http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html
(Reporter)

Comment 4

12 years ago
I crashed this pretty easily upon upgrading to Flash Player 8.0r22, but I can't
reproduce on demand.
(Reporter)

Comment 5

12 years ago
This looks like the same problem as bug 311399.
(Assignee)

Comment 6

12 years ago
I am so far unable to repro the crash.

If the fix for bug 311399 doesn't resolve this issue, please let me know.
(Reporter)

Comment 7

12 years ago
This should be fixed on the trunk now, after the latest checkin from bug 311399.
(Reporter)

Comment 8

12 years ago
These crashes have disappeared after the good patch in bug 311399 landed.

*** This bug has been marked as a duplicate of 311399 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Crash Signature: [@ QDPlatformGlobalToLocal()]
You need to log in before you can comment on or make changes to this bug.