The URL "http://http" gets redirected to www.microsoft.com!

VERIFIED DUPLICATE of bug 231720

Status

()

VERIFIED DUPLICATE of bug 231720
13 years ago
13 years ago

People

(Reporter: ramon.casha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051001 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051001 Firefox/1.0.7

A website I visited had an incorrect URL "http://http://www.jetbrains.com" - and
Firefox redirected to www.microsoft.com instead. I checked same URL with
Konqueror and it just gave an error message.

Apparently Microsoft registered their site with the "http" keyword in google.
Sneaky buggers!

Personally I think Firefox should not do keyword-searching if the URL contains
the "http://" (or similar) prefix - keywords should only be used when no
protocol part is included in the URL.

Reproducible: Always

Comment 1

13 years ago
We automatically do a keyword search for non-URLs. You can configure the URL it
searches with keyword.URL and whether the pref. is enabled with keyword.enabled
all in about:config. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
The problem is, the keyword searching is invoked not only on non-URLs, but *on
URLs too*. Basically, if the browser cannot immediately resolve a URL it
automatically interprets it as a keyword, even if it's a complete URL with
http://, server, path, query string etc. - in fact, keyword-searching will even
be invoked on links that the user clicks on in a page! 
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
(In reply to comment #2)
> The problem is, the keyword searching is invoked not only on non-URLs, but *on
> URLs too*. Basically, if the browser cannot immediately resolve a URL it
> automatically interprets it as a keyword, even if it's a complete URL with
> http://, server, path, query string etc. - in fact, keyword-searching will even
> be invoked on links that the user clicks on in a page! 

that's bug 245597
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.