All users were logged out of Bugzilla on October 13th, 2018

Intelligent bookmark handling according to HTTP response codes

RESOLVED DUPLICATE of bug 213467

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 213467
13 years ago
13 years ago

People

(Reporter: sabberworm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050930 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050930 Firefox/1.4

This is an enhancement request for "intelligent" bookmark handling. The concept
is quite simple really and quite useful also:
1. If the user opens a bookmark to which the server responds with a permanent
redirect response (or possibly also a redirect using meta hhtp-equiv), the user
should be asked if he wants to update his bookmarks accordingly.
2. If the user opens a bookmark to which the server responds with a 410 (or
possibly also 404) error code, the user should be asked if he wants to remove
the bookmark.
I imagine, this would make bookmark handling a lot less of a hassle dealing with
ever-changing URLs these days. I realise that this would also not be very easy
to implement because of the browser having to talk back to the bookmarks component.

Reproducible: Always

Steps to Reproduce:
Part 1 is bug 213467
Part 2 is bug 301144

*** This bug has been marked as a duplicate of 213467 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.