Support filtering RSS by "Website"

RESOLVED WORKSFORME

Status

MailNews Core
Filters
--
enhancement
RESOLVED WORKSFORME
13 years ago
4 years ago

People

(Reporter: Josh Watson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

The RSS messages appear to have a Website: header field.

I don't want to see nytimes select messages from Google News, I'm not a
subscriber and it annoys me to click a link and get "pay us money...".

So, I set a filter on the "Website" field (which I had to define myself) for:

Match Any
("Website") ("Contains" also tried "Begins With") ("http://select.nytimes.com/")

then
Delete message
I also tried: 
Move to Trash

These rules have no effect, whether on incoming messages or run on my google
news folder.

Reproducible: Always

Steps to Reproduce:
1. Define Website as a field
2. set a filter on the "Website" field for RSS account
3. Run Filter
Actual Results:  
Nowt. Nothing is logged to the filter log either.

Expected Results:  
Selected messages are removed.

Updated

13 years ago
Summary: Message Filters filteringRSS by Website do not appear to apply → Message Filters filtering RSS by Website do not appear to apply

Comment 1

13 years ago
RSS items are constructed by Thunderbird from the feed.  If you look at the 
source, there is no "Website:" header.  The "Website:" field in the envelope 
appears to be initialized from the item's "Message-Id:" header -- so try 
defining that header instead, and filtering on it.

Note that some filter actions do not work on RSS (bug 264382).
(Reporter)

Comment 2

13 years ago
Thanks Mike, using Content-Base instead of Website makes a good workaround
(along with using Move to Trash instead of Delete to get rid of it).

However, I'm from a technical background, I just don't know much about RSS. This
behaviour will definitely confuse a non-technical user. It appears to the user
that an RSS message has a Website field, so they may well expect Thunderbird to
be able to filter on it.

Comment 3

13 years ago
(In reply to comment #2)
> This behaviour will definitely confuse a non-technical user. It appears to
> the user that an RSS message has a Website field, so they may well expect
> Thunderbird to be able to filter on it.

Fair enough; let's make this an enhancement request.  I doubt this will change 
to make a "Website" header, but the there could easily be a special "website" 
criterion for RSS filtering.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Message Filters filtering RSS by Website do not appear to apply → Support filtering RSS by "Website"
Version: unspecified → Trunk

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Updated

7 years ago
Component: Feed Reader → Filters
QA Contact: feed.reader → filters

Updated

4 years ago
Duplicate of this bug: 378343

Comment 5

4 years ago
For a custom header, the actual header name is used in the display (label attribute) and must also be used for the search and be specific (case, ascii per header naming rfc). Changing this design is not likely as it's not trivial.

The need for Content-Base to search for a feed's website link is documented here:
https://support.mozilla.org/en-US/kb/how-subscribe-news-feeds-and-blogs
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.