Closed Bug 312251 Opened 14 years ago Closed 4 years ago

onunload=alert causes some focus selection issues when closing tab

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

Details

(Keywords: regression, testcase)

Attachments

(1 file)

See upcoming testcase.

To reproduce:
- Open testcase in new tab
- Select the newly created tab with the testcase
- Middle-click to close the tab.
- Now select some text and right-click to bring up the context menu

Result:
The generic context menu comes up, but you should get the 'special' context
menu, when a selection has been made.

This regressed between 2005-01-19 and 2005-01-20:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-01-19+17%3A00%3A00&maxdate=2005-01-20+23%3A50%3A00&cvsroot=%2Fcvsroot
The only bug I can think of is bug 244366.
Attached file testcase
Is this windows-only?  middle-click doesn't close tabs on Linux...
Well, I get the bug also when right-clicking on the tab and clicking on 'Close
Tab' in the popup menu.
It also affects input fields and their context menu.
Yeah, sounds windows-only -- I can't reproduce this on Linux.

That said, does the focus-suppression thing mrbkap landed yesterday help here?
You meant bug 309027, right? I'm still getting this bug with the 2005-10-24 trunk build.
Yeah, that's the one I meant.
Assignee: events → nobody
QA Contact: ian → events
This is wfm now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.