If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onscroll event in body element is not invoke when using mouse wheel or keyboard

RESOLVED DUPLICATE of bug 189308

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 189308
12 years ago
12 years ago

People

(Reporter: tempolary, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

onscroll event in body element is not invoke when using mouse wheel or keyboard.

Reproducible: Always

Steps to Reproduce:
1.Create page with content: 

<html>
<body onscroll='alert("Scrolling")'>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
</body>
</html>

Actual Results:  
When you are scrolling page by scroll onscroll event is invoked (you will see
messagebox), but try to scroll page by mouse wheel or by keyboard

Expected Results:  
Invoke onscroll event

Comment 1

12 years ago
This has been fixed, please test with lastest beta release before filing bugs,
thanks:
http://www.mozilla.org/projects/firefox/

*** This bug has been marked as a duplicate of 189308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.