Last Comment Bug 312309 - Prettier canvas image resampling/resizing when using drawImage
: Prettier canvas image resampling/resizing when using drawImage
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 05:55 PDT by Kamiel Martinet
Modified: 2011-10-05 08:38 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Kamiel Martinet 2005-10-13 05:55:59 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051011 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051011 Firefox/1.4.1

This isn't really a bug but I find it extremely annoying. Currently when using
the drawWindow or drawImage methods to render scaled bitmaps a resampling method
is used that looks almost but not quite like nearest neighbor. (tested on
windows and linux)

This is very obvious when drawing thumbnails of windows using drawWindow. Text
becomes a complete mess and it's very hard to make out even large headers.

Reproducible: Always
Comment 1 Nickolay_Ponomarev 2005-12-18 11:05:05 PST
confirming and tweaking summary to make it easier to find.
Comment 2 David E. Weekly 2007-06-14 20:26:01 PDT
This bug seems a duplicate of 372462. Additionally, the original bug 98971 does not actually seem fixed, at least for downsized images in 2.0.0.4.
Comment 3 Dave Townsend [:mossop] 2007-06-15 01:51:05 PDT
It's possible they could get fixed by the same thing but these are two quite different circumstances that certainly warrant individual attention.

I'm moving this to trunk since I don't believe any fix here would make the branch now.
Comment 4 David E. Weekly 2007-06-15 02:01:24 PDT
At least in my nightly (20070614), trunk has very pretty resampling - I'd call this fixed in trunk. Sounds like consensus is to punt on any attempt to fix this in 2.* and just focus on 3.0, which is fair.
Comment 5 Joe Drew (not getting mail) 2008-03-04 12:17:39 PST
We can probably just close this as fixed, then, correct?
Comment 6 Bas Schouten (:bas.schouten) 2011-10-05 08:38:34 PDT
An issue possibly left here is that linear interpolation downsampling like we're using on most platforms breaks down when you're downsizing by more than a factor of 2. This is a separate issue though and not specific to canvas, there's already bugs on this.

Note You need to log in before you can comment on or make changes to this bug.