If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.
Bug 312336 (PR)

Error occured during installation

RESOLVED DUPLICATE of bug 328579

Status

()

Firefox
Installer
--
blocker
RESOLVED DUPLICATE of bug 328579
12 years ago
12 years ago

People

(Reporter: prabhuraj78, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; {76FBF7ED-C75F-AD34-8E96-750B4A5F9A33}; .NET CLR 1.1.4322)
Build Identifier: Firefox Setup 1.0.7

When I am instaling Firefox 1.0.7 I got an error popup is displayed. 
"Error occured during installation - Cross-Platform COM -322 INIT_STUB_ERROR"
with OK button. 
After that my installation window is disabled and its not proceeding the 
installing. Please help me in this regard.

Reproducible: Always

Steps to Reproduce:
1.Double click the firefox setup 1.0.7.exe file.
2.Select Next button.
3.Select "I Accept..." and select Next button.
4.Select Next button two times, then this error message is displayed.
Actual Results:  
Error message popup window is dislayed and the installation is stopped.

Expected Results:  
It should tell the user why this error is displayed and should guide the user 
what he/she has to do after getting this error message.

Kindly do the needfull.
(Reporter)

Updated

12 years ago
Alias: PR
Summary: Error occured during installation → Error occured during installation
Version: unspecified → 1.0 Branch
1. where did you download that build from ?
2. is it en-US or another locatisation ?
Reporter, please download and install a recent nightly build available at http://www.mozilla.org/developer so that it can be verified that this problem still exists. Also, please provide answers for Peter's questions in comment 1 so that we may triage this report accurately.

Comment 3

12 years ago
I am receiving this error trying to install the current nightly build of 1.6a1 (Feb 23rd 8:30 CDT).  I have installed two previously nightly builds in the last week and they were working flawlessly.  I've tried uninstalling the previously nightly build and reinstalling the current one.  Same problem.  Previous nightly build Gecko/20060221 Firefox/1.6a1 reinstalled fine and am using it to report this.

Error I'm receiving is the same as the one reported here on much earlier version.
"Error occured during installation - Cross-Platform COM:322 INIT_STUB_ERROR" appears in "Error" dialog.  Installation aborts on OK of error dialog.  

I've tried installing with "Standard" and with "Custom" option with both developer tools and feedback agent selected.  Error occurs almost immediately after file installation process appears to begin.
<- NEW per comment #3.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

12 years ago
Downloaded latest nightly as of Sat 2/25/2006 5:30 CDT to see if this is fixed.  Still unable to install this nightly, but the problem has changed.  Here's what I'm getting now.

After going through all the normal preinstallation dialogs, I got to the Installing page of the wizard.  
Almost immediately (before the progress bar started doing anything), the install errored out.  
Here's  what the installation window looked like at the time of the error:

Installing
     --- Installing Deer Park....

Preparing Install, please wait...
     -- Empty Progress Bar

Here how the error occured.

Popup Error Dialog titled: Microsoft Visua C++ - Runtime Library appeared.
Contents:
Red Error icon: 
Runtime Error!
Program C:\DOCUME~1\Todd\LOCALS~1\Temp\7zSC6.tmp\setup.exe

R6034
An application has made an attempt to load the C runtime library incorrectly.
Please contact the application's support team for more information.

		OK

Pressed OK.  Dialog disappeared.
New Popup Error Dialog titled: Error appeared
Contents:
Yellow Caution Icon:
1114: Could not load C:\DOCUME~1\Todd\LOCALS~1\Temp\ff_temp\xpcom.ns\bin\xpistub.dll

		OK

Pressed OK.  Dialog disappeared.
Install window remains on screen in same state as described above.
Probably should be duped to bug 328579 or resolved otherwise, since it was originally reported on a 1.0.x build, and the recent comments are just symptoms of 328579...
<- DUPE bug 328579 per comment 6.

*** This bug has been marked as a duplicate of 328579 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.