When selecting text to print, pages break in the middle of printed lines

RESOLVED DUPLICATE of bug 240625

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 240625
12 years ago
11 years ago

People

(Reporter: windaria, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

While I can print the page, and it prints fine, any time I select a range of
text to print (in order to print selection, that way I can just print the body
of a web page and not print the side bar of the page) and then print the page,
the page breaks in the middle of lines, instead of always breaking between lines
as to not cut the words on the line in half, with the top half being at the
bottom of the page and the bottom half of the line being at the top of the next
page. If I print the doucment normally this does not happen. This is true for
this page as well as any other page on which an image is selected.

I could find no other mention of this bug. I have a Canon i9100 and am using
Firefox Beta 2 for Windows 2000.

Reproducible: Always

Steps to Reproduce:
1. Select a long section of text to print, ideally one that will span more than
two pages (to ensure that on at least one of the pages the text breaks in the
middle of a line)
2. Go to file > Print and select Selection
3. Click OK

Actual Results:  
As specified in Details, lines of text are cut when printing.

Expected Results:  
Text should be cut inbetween lines, so that all lines can be read as normal.

I am not entirely sure that I have the correct severity selected, however I
decided to go with Major because printing selections of web pages is a major
feature, at least as far as I am concerned, and thusly qualifies it as greater
than Normal.

Comment 1

12 years ago
I can confirm that this has been a bug since Firefox 1.0 and still exists in 1.5
beta 2.

OS: Windows XP SP2
Printer: HP Deskjst 5550

Mozilla Forum Topic:
http://forums.mozillazine.org/viewtopic.php?t=320105

Comment 2

12 years ago
Duplicate of/related to Core bug 240625?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 240625
You need to log in before you can comment on or make changes to this bug.