URLs concatenated when opening a home page tab group from desktop icon

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Sherman Wang, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey1.0.1, fixed-seamonkey1.1a})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051012 SeaMonkey/1.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051012 SeaMonkey/1.0b

When Mozilla/Seamonkey is loaded and a new window is opened from the desktop
icon, if a tab group is set as the home page the URLs will be concatenated in
the location bar.  Only one window is opened with no additional tabs. 
Subsequently, the page loads fail due to the concatenated URLs (unless
about:blank is used).

Reproducible: Always

Steps to Reproduce:
1. set a group of tabs as the home page
2. open a new window via desktop icon
3. view the page load fail

Actual Results:  
New window opened with URLs concatenated, no tabs open.  (eg
about:blankabout:blank or http://www.google.com/http://slashdot.org/ )

Expected Results:  
New window with several tabs open, one site per tab (eg http://www.google.com/in
one tab, http://slashdot.org/ in another).

currently using adblock d2 nightly build 52.  same results with adblock disabled
as well as enabled.

Comment 1

12 years ago
See Firefox bug 293396.

Comment 2

12 years ago
What happens when you click the home button? Do you see the same problem, or do
you actually get all the tabs you're expecting?
(Assignee)

Comment 3

12 years ago
SeaMonkey can now open external links in new tabs. When you don't provide an
external link it attempts to open the home page in a new tab. Unfortunately
danm's API doesn't allow for opening multiple tabs.

We can just not open the home page in a new tab, or we can detect whether the
home page is a group, and force it to open in a window. Any other ideas?

Note that as a workaround you can force the home page to open in a new window by
ticking the Navigator checkbox in the Appearance section of Preferences.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

12 years ago
when I click on the home button after getting something like
"http://www.google.com/http://slashdot.org/" in the URL bar, Seamonkey opens the
tabs as expected.
(Assignee)

Comment 5

12 years ago
Created attachment 199912 [details] [diff] [review]
Proposed patch
Assignee: general → neil.parkwaycc.co.uk
Status: NEW → ASSIGNED
Attachment #199912 - Flags: superreview?(jag)
Attachment #199912 - Flags: review?(cbiesinger)

Updated

12 years ago
Attachment #199912 - Flags: superreview?(jag) → superreview+
Attachment #199912 - Flags: review?(cbiesinger) → review+
(Assignee)

Comment 6

12 years ago
Fix checked in.
Blocks: 300485
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

11 years ago
Comment on attachment 199912 [details] [diff] [review]
Proposed patch

Also 1.0.1 I guess :-[
Attachment #199912 - Flags: approval-seamonkey1.1a?

Comment 8

11 years ago
Comment on attachment 199912 [details] [diff] [review]
Proposed patch

a=me for SM1.1 and a=me for first one for SM1.0.1 (or do we jump to 1.0.2 to sync with FF?)
Attachment #199912 - Flags: approval-seamonkey1.1a? → approval-seamonkey1.1a+

Comment 9

11 years ago
Comment on attachment 199912 [details] [diff] [review]
Proposed patch

a=me for SM1.0, some more needed yet
Attachment #199912 - Flags: approval-seamonkey1.0?
(Assignee)

Comment 10

11 years ago
KaiRo didn't mark a+ because it's 1.0.1 :-P
Keywords: fixed-seamonkey1.1a
Whiteboard: fixed-seamonkey1.0.1

Comment 11

11 years ago
Comment on attachment 199912 [details] [diff] [review]
Proposed patch

a=me for 1.0.1 - nite that this is the wrong flag, as 1.0 is out already, (ab)using it for this though, as we don't have a 1.0.1 flag yet...
Attachment #199912 - Flags: approval-seamonkey1.0? → approval-seamonkey1.0+

Updated

11 years ago
Keywords: fixed-seamonkey1.0.1
Whiteboard: fixed-seamonkey1.0.1

Comment 12

11 years ago
Comment on attachment 199912 [details] [diff] [review]
Proposed patch

move to the correct flag :)
Attachment #199912 - Flags: approval-seamonkey1.0+ → approval-seamonkey1.0.1+
You need to log in before you can comment on or make changes to this bug.