Firefox hangs (100% cpu load) when loading search results page on telefoongids.nl

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: g.teunis, Assigned: darin.moz)

Tracking

({hang, regression, testcase})

Trunk
x86
Windows XP
hang, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051014 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051014 Firefox/1.6a1

When using the "De Bedrijvengids" search on telefoongids.nl, firefox hangs at
100% cpu load. It is only triggered when entering a search query in "Wat" below
"De Bedrijvengids" (red search), do not anything in Regio.

Reproducible: Always

Steps to Reproduce:
1. Go to www.telefoongids.nl
2. Enter some text in the "Wat" searchbox in the red "De Bedrijvengids" section
3. Do not enter anything in  "Regio" (important!)
4. Click on "Zoek"

Actual Results:  
Firefox hangs at 100% cpu load, result page is sometimes partly loaded.

Expected Results:  
The page should load fine, without 100% cpu load.

I've tested it with a clean profile (without extensions and no tweaked settings).
I've set the Severity to Critical (firefox hangs), I can imagine that it is too
high> correct accordingly.
(Reporter)

Updated

13 years ago
Summary: Firefox hangs (100% cpu load) when loading search results page → Firefox hangs (100% cpu load) when loading search results page on telefoongids.nl
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051014
Firefox/1.4.1 ID:2005101422

Yes, I see this too.
When I fill in "computer" it hangs, but with "pyriet", "kwarts" or "carduelis"
it has no problem. 
Had to go far back, but it is a regression: 29-Jul-2004 - 30-Jul-2004.
On 29-Jul-2004 I got a list of results for "computer". 
(Reporter)

Comment 4

13 years ago
(In reply to comment #2)
> Had to go far back, but it is a regression: 29-Jul-2004 - 30-Jul-2004.
> On 29-Jul-2004 I got a list of results for "computer". 

Great work!
I confirm it works in 29-Jul-2004 and breaks on 30-Jul-2004.

Checkins in that period
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?treeid=default&module=PhoenixTinderbox&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-07-29+08%3A06%3A00&maxdate=2004-07-30+07%3A59%3A00&cvsroot=%2Fcvsroot
New per comment 1.
Anyone knock up a testcase?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: hang, regression
Created attachment 199763 [details]
testcase

This is a minimised testcase that still freezes/hangs for me.
Looking at bonsai link, my guess would be that this happens because of this
check-in:
http://tinderbox.mozilla.org/bonsai/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/netwerk/protocol/http/src&command=DIFF_FRAMESET&file=nsHttpChannel.cpp&rev1=1.214&rev2=1.215&root=/cvsroot
Assignee: nobody → darin
Component: General → Networking
Keywords: testcase
Product: Firefox → Core
QA Contact: general → benc
Version: unspecified → Trunk
So is this basically bug 309424?
Depends on: 309424
(In reply to comment #8)
> So is this basically bug 309424?
Yes, the patch in that bug seems to fix this issue.
This is fixed by bug 309424.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.