window.onscroll event in javascript only fired if scrollbar pushed with mouse pointer, not if page is scrolled with keyboard or mousewheel.

RESOLVED DUPLICATE of bug 189308

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 189308
13 years ago
13 years ago

People

(Reporter: bennybolin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; sv-SE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; sv-SE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7 (ax)

window.onscroll event in javascript only fired if scrollbar pushed with mouse
pointer, not if page is scrolled with keyboard or mousewheel or any other way.

It does not work when anchor is clicked to navigate within the same page.

Reproducible: Always



Expected Results:  
Internet explorer always fires the event, as long the page scroll.
It does not matter how the scrolling is done.

The menu with anchors in top of webpage http://hem.bredband.net/benbol/is
designed to always be on top of the page, by using window.onscroll event.
But it only works when pushing the scrollbar with mouse pointer.

Comment 1

13 years ago
Fixed in nigtly builds/betas btw.

*** This bug has been marked as a duplicate of 189308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.