'overflow:scroll' stacking is now wrong

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: ian, Assigned: roc)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
See http://www.hixie.ch/tests/adhoc/css/overflow/002.html

It seems we are now treating overflow:scroll boxes as if they formed a stacking
context, which is wrong per 2.1.

We should fix this for 1.5.
(Reporter)

Updated

13 years ago
Flags: blocking1.8.1?

Comment 1

13 years ago
Just FYI, this regressed between 2005-05-30 06:00 and 2005-05-31 06:00.
I'm almost 100% sure it's because I started creating views for scrollframes in
bug 240276, which is now triggering bug 191830.

I don't think this can be fixed for 1.5. Fixing 191830 is much too much for
branch (although I plan to work on it soon for trunk). Removing the scrollframe
view would require some tricky work that would be timeconsuming and risky.

Comment 3

13 years ago
*sigh* make that 2005-03-30 and 2005-03-31 (instead of 2005-05-30 and 2005-05-31).
(Reporter)

Comment 4

13 years ago
(Frank: Thanks!)

roc: Fair enough. Pity. We really should have caught this earlier; what's our
story on regression testing for catching this kind of thing?
Frank says it's actually bug 288117. That's where I introduced the view for
scrollframes, so my analysis still holds.
We don't run systematic periodic layout regression tests. They probably would
have caught this bug if we had, since it's in your test suite, but my experience
has been (from when I was running automated tests) that the user testing we get
from nightly builds generally finds more regressions than automatic testing with
the test suites we have.
(Reporter)

Comment 7

13 years ago
The two aren't mutually exclusive. :-) The more coverage the better.
Yeah, I need to rescuscitate my regression testing scripts again ... and fix the
bugs that made painting nondeterministic on some of your testcases.
I think this is WFM in my debug build that has the "frame display lists" patch in it (bug 317375).
Depends on: 317375
Testcase doesn't work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060124 Firefox/1.6a1 ID:2006012405
(both boxes red, no white text in top box)

Testcase does work with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012613
(both boxes greem, white 'A' in top box)

--> RESOLVED FIXED (by bug 317375)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.