Last Comment Bug 312747 - Include line break info for text using white-space: pre
: Include line break info for text using white-space: pre
Status: VERIFIED FIXED
: access, fixed1.8
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
:
Mentors:
http://iwin.nws.noaa.gov/iwin/al/hour...
: 311299 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 11:24 PDT by Aaron Leventhal
Modified: 2005-10-23 13:09 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
If text has computed style of white-space: pre, then don't expose (1.11 KB, patch)
2005-10-17 11:41 PDT, Aaron Leventhal
roc: review+
bzbarsky: superreview+
asa: approval1.8rc1+
Details | Diff | Splinter Review

Description Aaron Leventhal 2005-10-17 11:24:00 PDT
Normally we clean out \r, \n and \t characters in the accessible names of
objects, because those are only indication of the formatting of the markup.

However, in the case of <pre> and other text formatted using white-space: pre
the line break info is important.

Oftentimes tabular information is rendered inaccessible because we remove
linebreak info. For example: http://iwin.nws.noaa.gov/iwin/al/hourly.html

To reproduce:
1. Go to above URL
2. Launch MSAA Inspect and position arrow of text
3. Notice that the accessible name is all on 1 line

What should happen:
Line breaks should be rendered in MSAA Inspect window
Comment 1 Aaron Leventhal 2005-10-17 11:41:36 PDT
Created attachment 199824 [details] [diff] [review]
If text has computed style of white-space: pre, then don't expose
Comment 2 Aaron Leventhal 2005-10-18 12:25:42 PDT
Comment on attachment 199824 [details] [diff] [review]
If text has computed style of white-space: pre, then don't expose

This has been tested by the screen reader vendors in a special build created
for them.
Comment 3 Aaron Leventhal 2005-10-19 14:08:23 PDT
Verified by Doug Geoffray from GW Micro.
Comment 4 Dan Kinnunen 2005-10-20 11:43:37 PDT
Verified that this has been fixed in dev build 10/19/05 build from aaron.
Comment 5 Aaron Leventhal 2005-10-23 13:09:55 PDT
*** Bug 311299 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.