Last Comment Bug 312788 - Crash exposing invisible plugins
: Crash exposing invisible plugins
Status: VERIFIED FIXED
: access, fixed1.8, sec508
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Aaron Leventhal
:
Mentors:
http://www.bbc.co.uk/radio/aod/networ...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-17 20:18 PDT by Aaron Leventhal
Modified: 2005-10-20 13:04 PDT (History)
0 users
mscott: blocking1.8rc1-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase. If the width and height are made non-zero then it does not crash when MSAA tools are used with it. (307 bytes, patch)
2005-10-17 20:24 PDT, Aaron Leventhal
no flags Details | Diff | Splinter Review
Testcase. If the width and height are made non-zero then it does not crash when MSAA tools are used with it. (307 bytes, text/html)
2005-10-17 20:24 PDT, Aaron Leventhal
no flags Details
Don't expose invisible plugins (0 area rect). While we're at it, make absolutely sure we don't ever try to create children for native accessibles (make native accessibles inherit from the leaf class) (3.30 KB, patch)
2005-10-17 20:31 PDT, Aaron Leventhal
parente: review+
bryner: superreview+
asa: approval1.8rc1+
Details | Diff | Splinter Review

Description Aaron Leventhal 2005-10-17 20:18:45 PDT
If a plugin has a width or height of 0 Firefox crashes while exposing the MSAA.

In any case, we don't want to expose invisible content via MSAA.
Comment 1 Aaron Leventhal 2005-10-17 20:24:10 PDT
Created attachment 199887 [details] [diff] [review]
Testcase. If the width and height are made non-zero then it does not crash when MSAA tools are used with it.
Comment 2 Aaron Leventhal 2005-10-17 20:24:24 PDT
Created attachment 199888 [details]
Testcase. If the width and height are made non-zero then it does not crash when MSAA tools are used with it.
Comment 3 Aaron Leventhal 2005-10-17 20:31:35 PDT
Created attachment 199889 [details] [diff] [review]
Don't expose invisible plugins (0 area rect). While we're at it, make absolutely sure we don't ever try to create children for native accessibles (make native accessibles inherit from the leaf class)
Comment 4 Aaron Leventhal 2005-10-17 20:34:00 PDT
This is important because invisible plugins are used to expose audio content,
for example on BBC's "listen live" links.
Comment 5 Scott MacGregor 2005-10-18 09:18:20 PDT
We're not going to block the release on this, but if this patch gets super
reviewed by jst, laned on the trunk and verified in the next couple of days,
nominate the patch for branch approval. Thanks.
Comment 6 Johnny Stenback (:jst, jst@mozilla.com) 2005-10-18 14:26:56 PDT
Comment on attachment 199889 [details] [diff] [review]
Don't expose invisible plugins (0 area rect). While we're at it, make absolutely sure we don't ever try to create children for native accessibles (make native accessibles inherit from the leaf class)

sr=jst too fwiw.
Comment 7 Dan Kinnunen 2005-10-20 11:44:22 PDT
Verified that this has been fixed in dev build 10/19/05 build from aaron.

Note You need to log in before you can comment on or make changes to this bug.