If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

@import css -- file not found, cache to be cleared manually

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: klaus schmid, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/14, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

I noticed (very probably after the web site was updated) that the page has not
loaded a style sheet (css file). This was inside the page:
 
<style type="text/css" media="all">
@import url(http://www.autoitscript.com/forum/style_images/css_14.css);
</style></head>

Entering the url in the address bar, Firefox answered with an alert 'file not
found'. Then I cleared the cache manually and it worked.

Reproducible: Didn't try

Steps to Reproduce:
1. view a page with a style sheet reference as mentioned in Details
2. change the name of the style sheet file
3. view it again

Actual Results:  
The style sheet was not loaded.

Expected Results:  
I assume the software should disregard/clean the cache whenever a file seems to
be missing.

Comment 1

12 years ago
Firefox 1.5.0.1

I have experienced this type of problem several times.
My homepage has an image http://azdomino.monrovia.com/monroviaweb.nsf/PassionVine.jpg!OpenImageResource
Once in a while, (perhaps once a month) the image will not be shown. I have _not_ manually deleted cache files. My antivirus _has not_ reported any viruses or trojans in many months. (and certainly not in this image.)

When I right-click and view image, Firefox reports "File not found" and has a try again button. Clicking try again or refresh does not get the image.

I ran a packet capture, and get this HTTP conversation when I click try again:

GET /monroviaweb.nsf/PassionVine.jpg!OpenImageResource HTTP/1.1
Host: azdomino.monrovia.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: zone=8
If-Modified-Since: Wed, 15 Mar 2006 19:48:36 GMT
If-None-Match: W/"MTAtODA4Ny04ODI1NzEzMjAwNkNEMTdCLTg4MjU3MTE4MDA2RDhCN0MtNkE4NjIxRUY2Q0ZBM0I3MTg4MjU3MTExMDAxQ0FFOTc="
Cache-Control: max-age=0


## and the response:

HTTP/1.1 304 Not Modified
Server: Lotus-Domino
Date: Thu, 23 Mar 2006 17:07:46 GMT
ETag: W/"MTAtODA4Ny04ODI1NzEzMjAwNkNEMTdCLTg4MjU3MTE4MDA2RDhCN0MtNkE4NjIxRUY2Q0ZBM0I3MTg4MjU3MTExMDAxQ0FFOTc="

The workaround is to shift-F5 to go around the cache, but this should not be needed. The image will also load if I change the url slightly, such as changing to a different FQDN that points at the same server, or adding a no-effect parameter to the query string.

I have seen variations of this bug reported in Bugzilla several times, but they try to explain it away as a manually deleted cache, or non-Moz programs messing the cache. I believe this is not the case here. The problem, of course, is trying to duplicate something that happens maybe once a month. Is it possible that Firefox starts cleaning a full cache _after_ it decides to use the image from cache?

Comment 2

12 years ago
Same problem on my Mac FF with an image-heavy browser game:

GET /Spiele/wizard/heads/0100020302000203.gif HTTP/1.1
Host: zockomat.de
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
Accept-Language: de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Cookie: ***(removed)***
If-Modified-Since: Fri, 04 Nov 2005 15:15:25 GMT
If-None-Match: "28c0ea-4859-c65b1d40"
Cache-Control: max-age=0

HTTP/1.x 304 Not Modified
Date: Mon, 24 Apr 2006 16:44:47 GMT
Server: Apache
Connection: Keep-Alive
Keep-Alive: timeout=15, max=100
Etag: "28c0ea-4859-c65b1d40"

Comment 3

11 years ago
I've been having this problem for the past 1 week+. On multiple sites I'm not loading CSS, even when I enter the URL directly. If I disable the cache using the Webdev extension, things load OK.

I'm on OS X 10.4. Not sure why the same bug can't be reported for multiple OSes.

Firefox 1.5.0.4
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch

Comment 5

10 years ago
Lack of comments as to the reproducibility of this issue. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.