Closed Bug 313130 Opened 16 years ago Closed 16 years ago

Always asks what to do with the file even though the "always do this with files like these" is checked.

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 236541

People

(Reporter: no, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Every time I download a file instead of opening the proper app automatically i
get the dialouge to select save or open with the associated app. The box that
says always do this with these files is checked...and it always asks...every
freaking time. 

Reproducible: Always

Steps to Reproduce:
1.click a torrent link on isohunt.com
2. check the box to always open with the seleted app...
3. repeat.

Actual Results:  
same dialouge...same problem

Expected Results:  
downloaded and opened the file in the associated application. not sure if it
matters but i have the option "hide the download window" activated. I dont see
the download window, but still have to select "open the file with" every time.
isohunt.com is using "Content-disposition: attachment" header, see bug 236541

*** This bug has been marked as a duplicate of 236541 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.